summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Ross <tross@apache.org>2011-01-06 19:37:55 +0000
committerTed Ross <tross@apache.org>2011-01-06 19:37:55 +0000
commit5107153dfe5dbba791b100fcf10f28363311443b (patch)
treeb3802d02229079b7dd436e01d32e103989932e70
parentc29d6794602213d5e57116abdda362a34688e935 (diff)
downloadqpid-python-5107153dfe5dbba791b100fcf10f28363311443b.tar.gz
Added outline for QMF content in docbook.
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1056031 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/doc/book/Makefile5
-rw-r--r--qpid/doc/book/src/QmfBook.xml101
-rw-r--r--qpid/doc/book/src/QmfIntroduction.xml45
3 files changed, 151 insertions, 0 deletions
diff --git a/qpid/doc/book/Makefile b/qpid/doc/book/Makefile
index 2145acc97c..db160ac6f8 100644
--- a/qpid/doc/book/Makefile
+++ b/qpid/doc/book/Makefile
@@ -35,6 +35,8 @@ java: build/AMQP-Messaging-Broker-Java-Book
programming: build/Programming-In-Apache-Qpid
+qmf: build/QmfBook
+
build/AMQP-Messaging-Broker-CPP-Book:
./build-book.sh AMQP-Messaging-Broker-CPP-Book
@@ -44,5 +46,8 @@ build/AMQP-Messaging-Broker-Java-Book:
build/Programming-In-Apache-Qpid:
./build-book.sh Programming-In-Apache-Qpid
+build/QmfBook: src/QmfBook.xml src/QmfIntroduction.xml
+ ./build-book.sh QmfBook
+
clean:
rm -rf build
diff --git a/qpid/doc/book/src/QmfBook.xml b/qpid/doc/book/src/QmfBook.xml
new file mode 100644
index 0000000000..64a6545fb5
--- /dev/null
+++ b/qpid/doc/book/src/QmfBook.xml
@@ -0,0 +1,101 @@
+<?xml version='1.0' encoding='utf-8' ?>
+<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN" "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+]>
+
+<!--
+
+ Licensed to the Apache Software Foundation (ASF) under one
+ or more contributor license agreements. See the NOTICE file
+ distributed with this work for additional information
+ regarding copyright ownership. The ASF licenses this file
+ to you under the Apache License, Version 2.0 (the
+ "License"); you may not use this file except in compliance
+ with the License. You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing,
+ software distributed under the License is distributed on an
+ "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ KIND, either express or implied. See the License for the
+ specific language governing permissions and limitations
+ under the License.
+
+ -->
+
+<book id="qmf-book">
+ <title>QMF - The Qpid Management Framework</title>
+ <subtitle>Object and Service-Oriented Management Leveraging the Capabilities of Qpid Messaging</subtitle>
+
+ <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="QmfIntroduction.xml"/>
+
+ <!-- As these chapters are fleshed out, move them into separate include files for easier text management -->
+ <chapter><title>QMF Architecture</title>
+ <section><title>Components: Agents and Consoles</title>
+ </section>
+ <section><title>QMF Domains</title>
+ </section>
+ <section><title>Data: Objects, Methods, Events, and Schemata</title>
+ </section>
+ <section><title>Agent Discovery</title>
+ </section>
+ <section><title>Data Access: Queries and Subscriptions</title>
+ </section>
+ </chapter>
+
+ <chapter><title>QMF Schema Definition</title>
+ <section><title>Packages, Objects, and Events</title>
+ </section>
+ <section><title>Data Types</title>
+ </section>
+ <section><title>Programmatic Schema Definition</title>
+ </section>
+ <section><title>XML Schema Definition</title>
+ </section>
+ </chapter>
+
+ <chapter><title>How to Write an Agent</title>
+ </chapter>
+
+ <chapter><title>How to Write a Console</title>
+ </chapter>
+
+ <chapter><title>QMF Queries</title>
+ </chapter>
+
+ <chapter><title>API Reference</title>
+ <section><title>C++ API</title>
+ </section>
+ <section><title>Python API</title>
+ </section>
+ <section><title>Ruby API</title>
+ </section>
+<!--
+ <section><title>.NET API</title>
+ </section>
+ <section><title>Java API</title>
+ </section>
+-->
+ </chapter>
+
+ <chapter><title>Scale: Large QMF Networks</title>
+ </chapter>
+
+ <chapter><title>Security</title>
+ </chapter>
+
+ <chapter><title>The QMF Protocol</title>
+ <section><title>Message Headers</title>
+ </section>
+ <section><title>Addressing</title>
+ </section>
+ <section><title>Message Protocol</title>
+ </section>
+ <section><title>Message Body Details</title>
+ </section>
+ </chapter>
+
+ <chapter><title>Using QMF Messages to Manage the Qpid Broker</title>
+ </chapter>
+
+</book>
diff --git a/qpid/doc/book/src/QmfIntroduction.xml b/qpid/doc/book/src/QmfIntroduction.xml
new file mode 100644
index 0000000000..db7b8949a5
--- /dev/null
+++ b/qpid/doc/book/src/QmfIntroduction.xml
@@ -0,0 +1,45 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!--
+
+ Licensed to the Apache Software Foundation (ASF) under one
+ or more contributor license agreements. See the NOTICE file
+ distributed with this work for additional information
+ regarding copyright ownership. The ASF licenses this file
+ to you under the Apache License, Version 2.0 (the
+ "License"); you may not use this file except in compliance
+ with the License. You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing,
+ software distributed under the License is distributed on an
+ "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ KIND, either express or implied. See the License for the
+ specific language governing permissions and limitations
+ under the License.
+
+-->
+
+<chapter>
+<title>Introduction</title>
+
+<para>
+QMF enhances Qpid Messaging by providing a layer of functionality that makes it easy to implement common management patterns
+using messaging as the basis for communication. QMF consists of three primary parts:
+</para>
+
+<itemizedlist>
+ <listitem><para>
+A protocol definition defines conventions for the use of message addresses, message headers, and structured message bodies.
+ </para></listitem>
+
+ <listitem><para>
+A core QMF engine provides a C++ API and an implementation of a set of protocol handlers for QMF message communication.
+ </para></listitem>
+
+ <listitem><para>
+Bindings are provided that wrap the C++ API for use in other languages such as Python, Ruby, and .NET.
+ </para></listitem>
+</itemizedlist>
+
+</chapter>