summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Ross <tross@apache.org>2011-04-27 17:02:40 +0000
committerTed Ross <tross@apache.org>2011-04-27 17:02:40 +0000
commit70973bf809ce4e94d2486e082bc2ab47290ee88e (patch)
tree49ea51a0625bf7964ad955127459cd7cdef4e91a
parent8f8946b25b3df2e6d53a26ffd2b0943d7f7ad3ae (diff)
downloadqpid-python-70973bf809ce4e94d2486e082bc2ab47290ee88e.tar.gz
NO-JIRA - Build fixes for saslwrapper:
- Add -fno-strict-aliasing to the compile flags for the c++ wrapper code - Ensure that the Python artifacts are installed in an arch-specific location git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1097181 13f79535-47bb-0310-9956-ffa450edef68
-rwxr-xr-xqpid/extras/sasl/bootstrap2
-rw-r--r--qpid/extras/sasl/configure.ac1
-rw-r--r--qpid/extras/sasl/python/Makefile.am3
-rw-r--r--qpid/extras/sasl/ruby/Makefile.am2
-rw-r--r--qpid/extras/sasl/src/Makefile.am1
5 files changed, 4 insertions, 5 deletions
diff --git a/qpid/extras/sasl/bootstrap b/qpid/extras/sasl/bootstrap
index 32085c325d..906e5a71e4 100755
--- a/qpid/extras/sasl/bootstrap
+++ b/qpid/extras/sasl/bootstrap
@@ -22,7 +22,7 @@ aclocal -I m4
autoheader
libtoolize --automake
-automake
+automake --add-missing
autoconf
if [ "$1" = "-build" -o "$1" = "--build" ] ; then
diff --git a/qpid/extras/sasl/configure.ac b/qpid/extras/sasl/configure.ac
index bc0fadbb31..206c2f497d 100644
--- a/qpid/extras/sasl/configure.ac
+++ b/qpid/extras/sasl/configure.ac
@@ -23,7 +23,6 @@ AC_CONFIG_HEADERS([config.h])
AC_PROG_CC_STDC
AM_PROG_CC_C_O
AC_PROG_CXX
-AC_USE_SYSTEM_EXTENSIONS
AC_LANG([C++])
# Check for optional use of help2man
diff --git a/qpid/extras/sasl/python/Makefile.am b/qpid/extras/sasl/python/Makefile.am
index 43eef70923..7c61f37cee 100644
--- a/qpid/extras/sasl/python/Makefile.am
+++ b/qpid/extras/sasl/python/Makefile.am
@@ -29,8 +29,7 @@ BUILT_SOURCES = $(generated_file_list)
$(generated_file_list): python.i $(top_srcdir)/src/saslwrapper.i
$(SWIG) -c++ -python -Wall -I/usr/include $(INCLUDES) -o saslwrapper.cpp $(srcdir)/python.i
-pylibdir = $(PYTHON_LIB)
-python_PYTHON = saslwrapper.py
+pyexec_PYTHON = saslwrapper.py
pyexec_LTLIBRARIES = _saslwrapper.la
_saslwrapper_la_LDFLAGS = -avoid-version -module -shared
diff --git a/qpid/extras/sasl/ruby/Makefile.am b/qpid/extras/sasl/ruby/Makefile.am
index da64239323..85fde1085d 100644
--- a/qpid/extras/sasl/ruby/Makefile.am
+++ b/qpid/extras/sasl/ruby/Makefile.am
@@ -35,7 +35,7 @@ rubylibarch_LTLIBRARIES = saslwrapper.la
saslwrapper_la_LDFLAGS = -avoid-version -module -shared ".$(RUBY_DLEXT)"
saslwrapper_la_LIBADD = $(RUBY_LIBS) $(top_builddir)/src/libsaslwrapper.la -lsasl2
-saslwrapper_la_CXXFLAGS = $(INCLUDES) -I$(RUBY_INC) -I$(RUBY_INC_ARCH)
+saslwrapper_la_CXXFLAGS = $(INCLUDES) -I$(RUBY_INC) -I$(RUBY_INC_ARCH) -fno-strict-aliasing
nodist_saslwrapper_la_SOURCES = saslwrapper.cpp
CLEANFILES = $(generated_file_list)
diff --git a/qpid/extras/sasl/src/Makefile.am b/qpid/extras/sasl/src/Makefile.am
index 25529a3607..c2aa8dd188 100644
--- a/qpid/extras/sasl/src/Makefile.am
+++ b/qpid/extras/sasl/src/Makefile.am
@@ -24,6 +24,7 @@ nobase_include_HEADERS = ../include/saslwrapper.h
lib_LTLIBRARIES = libsaslwrapper.la
libsaslwrapper_la_SOURCES = cyrus/saslwrapper.cpp
+libsaslwrapper_la_CXXFLAGS = -fno-strict-aliasing
# Library Version Information:
#