summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2011-06-07 19:32:01 +0000
committerAndrew Stitcher <astitcher@apache.org>2011-06-07 19:32:01 +0000
commit64131785f764add6086247aadc3e717a6ebeab33 (patch)
tree605f8175a5ba88f4a9d12fe85a425d7f7e6a2bfe
parent2eb56f820d6845bc96342191d9e90dd50dc76b0d (diff)
downloadqpid-python-64131785f764add6086247aadc3e717a6ebeab33.tar.gz
QPID-3295: Autoconf incorrectly detects gcc doesn't support -Werror
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1133137 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/qpid/cpp/configure.ac b/qpid/cpp/configure.ac
index 43a32d3ad7..092694d56b 100644
--- a/qpid/cpp/configure.ac
+++ b/qpid/cpp/configure.ac
@@ -68,8 +68,10 @@ if test x$GXX = xyes; then
# The following warnings are deliberately omitted, they warn on valid code.
# -Wunreachable-code -Wpadded -Winline
# -Wshadow - warns about boost headers.
+ # Can't test for -Werror as whether it fails or not depends on what's in
+ # CFLAGS/CXXFLAGS. In any case it's been in gcc for a long time (since 2.95 at least)
if test "${enableval}" = yes; then
- gl_COMPILER_FLAGS(-Werror)
+ COMPILER_FLAGS="-Werror"
gl_COMPILER_FLAGS(-pedantic)
gl_COMPILER_FLAGS(-Wall)
gl_COMPILER_FLAGS(-Wextra)