summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2012-02-17 14:17:06 +0000
committerAlan Conway <aconway@apache.org>2012-02-17 14:17:06 +0000
commit89966c062545b89b9d88e473d42c6e74cdd588df (patch)
treecdae7f6634a3989cd03ec96ead393a0b0d57c8a9
parentba7c291f099252bb38108744eb98ba69a8edacb6 (diff)
downloadqpid-python-89966c062545b89b9d88e473d42c6e74cdd588df.tar.gz
Revert "QPID-3603: Disable federation cluster tests on qpid-3603 branch."
This reverts commit f68ce76fcaadf52b93f58140173a1f48a371e007. git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/qpid-3603-7@1245554 13f79535-47bb-0310-9956-ffa450edef68
-rwxr-xr-xqpid/cpp/src/tests/run_federation_sys_tests17
1 files changed, 7 insertions, 10 deletions
diff --git a/qpid/cpp/src/tests/run_federation_sys_tests b/qpid/cpp/src/tests/run_federation_sys_tests
index 9b171cf166..f5f772d72e 100755
--- a/qpid/cpp/src/tests/run_federation_sys_tests
+++ b/qpid/cpp/src/tests/run_federation_sys_tests
@@ -25,16 +25,13 @@ source ./test_env.sh
MODULENAME=federation_sys
-# FIXME aconway 2011-12-15: Disable cluster-related tests on the qpid-3603
-# branch. See comment in cluster.mk for more details.
-#
-# # Test for clustering
-# ps -u root | grep 'aisexec\|corosync' > /dev/null
-# if (( $? == 0 )); then
-# CLUSTERING_ENABLED=1
-# else
-# echo "WARNING: No clustering detected; tests using it will be ignored."
-# fi
+# Test for clustering
+ps -u root | grep 'aisexec\|corosync' > /dev/null
+if (( $? == 0 )); then
+ CLUSTERING_ENABLED=1
+else
+ echo "WARNING: No clustering detected; tests using it will be ignored."
+fi
# Test for long test
if [[ "$1" == "LONG_TEST" ]]; then