summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2012-02-17 14:16:59 +0000
committerAlan Conway <aconway@apache.org>2012-02-17 14:16:59 +0000
commitba7c291f099252bb38108744eb98ba69a8edacb6 (patch)
treeaf48e8a755174e93d776db92419008da54fdc28c
parent2fec341a0a1aed8ce440e956cf97d882f83a42b3 (diff)
downloadqpid-python-ba7c291f099252bb38108744eb98ba69a8edacb6.tar.gz
Revert "QPID-3603: disable old cluster tests"
This reverts commit 4e6163d24a4520a288981865ca20d9e1dff6e9d1. git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/qpid-3603-7@1245553 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/tests/cluster.mk28
1 files changed, 9 insertions, 19 deletions
diff --git a/qpid/cpp/src/tests/cluster.mk b/qpid/cpp/src/tests/cluster.mk
index 424d4169e8..199d1e7b57 100644
--- a/qpid/cpp/src/tests/cluster.mk
+++ b/qpid/cpp/src/tests/cluster.mk
@@ -61,25 +61,15 @@ if HAVE_LIBCPG
# You should do "newgrp ais" before running the tests to run these.
#
-# FIXME aconway 2011-11-14: Disable cluster tests on qpid-3603 branch
-# Some cluster tests are known to fail on this branch.
-# Immediate priority is to develop then new HA solution,
-# Cluster will brought up to date when thats done.
-#
-# gsim: its due to the keeping of deleted messages on the deque until they can be popped off either end
-# gsim: that is state that isn't available to new nodes of course
-# gsim: i.e. if you dequeue a message from the middle of the deque
-# gsim: it will not be on updatee but will be hidden on original node(s)
-# gsim: and is needed for the direct indexing
-
-
-# TESTS += \
-# run_cluster_test \
-# cluster_read_credit \
-# test_watchdog \
-# run_cluster_tests \
-# federated_cluster_test \
-# clustered_replication_test
+
+# ais_check checks pre-requisites for cluster tests and runs them if ok.
+TESTS += \
+ run_cluster_test \
+ cluster_read_credit \
+ test_watchdog \
+ run_cluster_tests \
+ federated_cluster_test \
+ clustered_replication_test
# Clean up after cluster_test and start_cluster
CLEANFILES += cluster_test.acl cluster.ports