summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharles E. Rolke <chug@apache.org>2011-11-08 22:49:34 +0000
committerCharles E. Rolke <chug@apache.org>2011-11-08 22:49:34 +0000
commitb96bc9ca8d656177859ae847b54e9189867fcf4f (patch)
treeb70f711c15f1b2392b2daf6d75b955f09065f1f3
parentbd89b9eb0748dfed9893a325922cfd4862c5a203 (diff)
downloadqpid-python-b96bc9ca8d656177859ae847b54e9189867fcf4f.tar.gz
QPID-2640 Visual Studio 2010
Add new pdb-name munging logic for 2010. Add Boost_ADDITIONAL_VERSION setting to aid windows-based cmake. git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1199507 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index a903de2cc2..100f7dfe60 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -46,7 +46,8 @@ MACRO (install_pdb theLibrary theComponent)
if (MSVC)
get_target_property(library_dll ${theLibrary} LOCATION)
string(REPLACE .dll .pdb library_pdb ${library_dll})
- string(REPLACE $(OutDir) \${CMAKE_INSTALL_CONFIG_NAME} library_pdb ${library_pdb})
+ string(REPLACE $(OutDir) \${CMAKE_INSTALL_CONFIG_NAME} library_pdb ${library_pdb})
+ string(REPLACE $(Configuration) \${CMAKE_INSTALL_CONFIG_NAME} library_pdb ${library_pdb})
string(REPLACE .pdb d.pdb libraryd_pdb ${library_pdb})
#message(STATUS "_pdb: ${library_pdb}, ${libraryd_pdb}")
install (PROGRAMS
@@ -290,6 +291,14 @@ else (CMAKE_SYSTEM_NAME STREQUAL Windows)
set (Boost_components filesystem program_options unit_test_framework)
endif (CMAKE_SYSTEM_NAME STREQUAL Windows)
+# Visual Studio 2010 requires boost 1.45 or better.
+# The choice here is to fail demanding the user to update CMake to version N
+# where Boost 1.45 is supported, or we can just accept some versions using
+# the Additional_versions variable.
+if (NOT DEFINED Boost_ADDITIONAL_VERSIONS)
+ set (Boost_ADDITIONAL_VERSIONS "1.45" "1.45.0" "1.46" "1.46.0" "1.47" "1.47.0")
+endif (NOT DEFINED Boost_ADDITIONAL_VERSIONS)
+
find_package(Boost 1.33 REQUIRED COMPONENTS ${Boost_components})
if(NOT Boost_FOUND)
message(FATAL_ERROR "Boost C++ libraries not found. Please install or try setting BOOST_ROOT")