summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2011-11-09 15:54:12 +0000
committerAndrew Stitcher <astitcher@apache.org>2011-11-09 15:54:12 +0000
commit80ac5f29701a339993fdae3096d32a48bdbce7e1 (patch)
treec57ca475a907bd1345b9b8f0416b69a9f5cb498b
parent8060cc2e022de2c8f6930f768edd73510e67d3d2 (diff)
downloadqpid-python-80ac5f29701a339993fdae3096d32a48bdbce7e1.tar.gz
QPID-3586: Changes for QPID-3464 break cmake build in tar.gz distribution
- The previous fix for this problem broke the autotools build, so remove the StoreStatus cluster test again from the autotools build. git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1199811 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/tests/cluster.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/qpid/cpp/src/tests/cluster.mk b/qpid/cpp/src/tests/cluster.mk
index 6db2215859..199d1e7b57 100644
--- a/qpid/cpp/src/tests/cluster.mk
+++ b/qpid/cpp/src/tests/cluster.mk
@@ -91,8 +91,11 @@ cluster_test_SOURCES = \
ForkedBroker.cpp \
PartialFailure.cpp \
ClusterFailover.cpp \
- InitialStatusMap.cpp \
- StoreStatus.cpp
+ InitialStatusMap.cpp
+
+# Moved this file here from cluster_test_SOURCES as it breaks the autotools build, but not the cmake
+# build and so we need to make sure it is present in the tarball
+EXTRA_DIST += StoreStatus.cpp
cluster_test_LDADD=$(lib_client) $(lib_broker) ../cluster.la -lboost_unit_test_framework