summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2011-11-03 14:31:39 +0000
committerAndrew Stitcher <astitcher@apache.org>2011-11-03 14:31:39 +0000
commit85b266fe8875fd8750f0f7808f2ad840ad249821 (patch)
tree91817fa867126efa15ab1eab855e2a3a572d9091
parent59d79aef097d13a4dd5d231d2f066ffae70ba31d (diff)
downloadqpid-python-85b266fe8875fd8750f0f7808f2ad840ad249821.tar.gz
QPID-3464: Build Improvements (CMake) [inspired by Jan-Marek Glogowski]
- Detect whether uuid library and headers are installed git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1197145 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index 62dce23a42..02db779e1b 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -458,6 +458,14 @@ else (NOT CLOCK_GETTIME_IN_RT)
set(QPID_HAS_CLOCK_GETTIME YES CACHE BOOL "Platform has clock_gettime")
endif (NOT CLOCK_GETTIME_IN_RT)
+# Ensure that we have uuid library
+CHECK_LIBRARY_EXISTS (uuid uuid_compare "" HAVE_UUID)
+CHECK_INCLUDE_FILES(uuid/uuid.h HAVE_UUID_H)
+IF (NOT HAVE_UUID AND NOT HAVE_UUID_H)
+ message(FATAL_ERROR "Uuid library and/or header file not found")
+ENDIF (NOT HAVE_UUID AND NOT HAVE_UUID_H)
+
+
# See if Cyrus SASL is desired and available
CHECK_LIBRARY_EXISTS (sasl2 sasl_checkpass "" HAVE_SASL)
CHECK_INCLUDE_FILES (sasl/sasl.h HAVE_SASL_H)