summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2011-11-03 21:17:49 +0000
committerAndrew Stitcher <astitcher@apache.org>2011-11-03 21:17:49 +0000
commitdf5ccab61279c6a2efe61df5e9d0791e944e66b8 (patch)
treef51a053f0c0561cca989c2802c5535e46ab3ffc8
parentb78ecf148fc47dc90c015720563df8a8357c28e5 (diff)
downloadqpid-python-df5ccab61279c6a2efe61df5e9d0791e944e66b8.tar.gz
QPID-3464: Build Improvements (CMake)
- Fixed windows build git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1197312 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index 2736500b45..a903de2cc2 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -460,12 +460,14 @@ else (NOT CLOCK_GETTIME_IN_RT)
set(QPID_HAS_CLOCK_GETTIME YES CACHE BOOL "Platform has clock_gettime")
endif (NOT CLOCK_GETTIME_IN_RT)
-# Ensure that we have uuid library
-CHECK_LIBRARY_EXISTS (uuid uuid_compare "" HAVE_UUID)
-CHECK_INCLUDE_FILES(uuid/uuid.h HAVE_UUID_H)
-IF (NOT HAVE_UUID AND NOT HAVE_UUID_H)
- message(FATAL_ERROR "Uuid library and/or header file not found")
-ENDIF (NOT HAVE_UUID AND NOT HAVE_UUID_H)
+# If not windows ensure that we have uuid library
+if (NOT CMAKE_SYSTEM_NAME STREQUAL Windows)
+ CHECK_LIBRARY_EXISTS (uuid uuid_compare "" HAVE_UUID)
+ CHECK_INCLUDE_FILES(uuid/uuid.h HAVE_UUID_H)
+ if (NOT HAVE_UUID AND NOT HAVE_UUID_H)
+ message(FATAL_ERROR "Uuid library and/or header file not found")
+ endif (NOT HAVE_UUID AND NOT HAVE_UUID_H)
+endif (NOT CMAKE_SYSTEM_NAME STREQUAL Windows)
# See if Cyrus SASL is desired and available
CHECK_LIBRARY_EXISTS (sasl2 sasl_checkpass "" HAVE_SASL)