summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Ross <tross@apache.org>2009-01-16 20:09:39 +0000
committerTed Ross <tross@apache.org>2009-01-16 20:09:39 +0000
commit6e3da22fc4946b299d6d5a20f0564d762b8e47bf (patch)
treefd94705078ff7bfc77ace97ad1222ec154107887
parent46e82569f85137c8cd8cee3fe86fe4efc662e7f3 (diff)
downloadqpid-python-6e3da22fc4946b299d6d5a20f0564d762b8e47bf.tar.gz
QPID-1588 - Fixed bug in asynchronous API operations.
Added a new example to demonstrate async ops. git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@735115 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/examples/qmf-console/Makefile.am6
-rw-r--r--qpid/cpp/examples/qmf-console/printevents.cpp2
-rw-r--r--qpid/cpp/examples/qmf-console/queuestats.cpp141
-rw-r--r--qpid/cpp/src/qpid/console/SessionManager.cpp2
-rw-r--r--qpid/cpp/src/tests/ManagementTest.cpp27
5 files changed, 175 insertions, 3 deletions
diff --git a/qpid/cpp/examples/qmf-console/Makefile.am b/qpid/cpp/examples/qmf-console/Makefile.am
index e115fc0fb0..471620f465 100644
--- a/qpid/cpp/examples/qmf-console/Makefile.am
+++ b/qpid/cpp/examples/qmf-console/Makefile.am
@@ -22,7 +22,7 @@ examplesdir=$(pkgdatadir)/examples/qmf-console
MAKELDFLAG = qmfconsole
include $(top_srcdir)/examples/makedist.mk
-noinst_PROGRAMS=console printevents ping
+noinst_PROGRAMS=console printevents ping queuestats
console_SOURCES=console.cpp
console_LDADD=$(CONSOLE_LIB)
@@ -33,9 +33,13 @@ printevents_LDADD=$(CONSOLE_LIB)
ping_SOURCES=ping.cpp
ping_LDADD=$(CONSOLE_LIB)
+queuestats_SOURCES=queuestats.cpp
+queuestats_LDADD=$(CONSOLE_LIB)
+
examples_DATA= \
console.cpp \
printevents.cpp \
ping.cpp \
+ queuestats.cpp \
$(MAKEDIST)
diff --git a/qpid/cpp/examples/qmf-console/printevents.cpp b/qpid/cpp/examples/qmf-console/printevents.cpp
index bbec2c1af0..38d6f830aa 100644
--- a/qpid/cpp/examples/qmf-console/printevents.cpp
+++ b/qpid/cpp/examples/qmf-console/printevents.cpp
@@ -37,7 +37,7 @@ public:
}
void brokerDisconnected(const Broker& broker) {
- cout << qpid::sys::now() << " NOTIC qpid-printevents:brokerDisonnected broker=" <<
+ cout << qpid::sys::now() << " NOTIC qpid-printevents:brokerDisconnected broker=" <<
broker.getUrl() << endl;
}
diff --git a/qpid/cpp/examples/qmf-console/queuestats.cpp b/qpid/cpp/examples/qmf-console/queuestats.cpp
new file mode 100644
index 0000000000..ea6dc13022
--- /dev/null
+++ b/qpid/cpp/examples/qmf-console/queuestats.cpp
@@ -0,0 +1,141 @@
+/*
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one
+ * or more contributor license agreements. See the NOTICE file
+ * distributed with this work for additional information
+ * regarding copyright ownership. The ASF licenses this file
+ * to you under the Apache License, Version 2.0 (the
+ * "License"); you may not use this file except in compliance
+ * with the License. You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing,
+ * software distributed under the License is distributed on an
+ * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ * KIND, either express or implied. See the License for the
+ * specific language governing permissions and limitations
+ * under the License.
+ *
+ */
+
+#include "qpid/console/ConsoleListener.h"
+#include "qpid/console/SessionManager.h"
+
+using namespace std;
+using namespace qpid::console;
+
+//
+// Declare a subclass of ConsoleListener to receive asynchronous data.
+//
+class Listener : public ConsoleListener {
+
+ //
+ // Declare a map from ObjectId to string to store queue names by their object IDs.
+ //
+ typedef map<ObjectId, string> QueueMap;
+ QueueMap queueMap;
+public:
+ ~Listener() {}
+
+ //
+ // Receive property updates from the agent.
+ //
+ void objectProps(Broker& /*broker*/, Object& object) {
+ string name = object.attrString("name");
+ ObjectId oid = object.getObjectId();
+ QueueMap::iterator iter = queueMap.find(oid);
+
+ if (iter == queueMap.end()) {
+ //
+ // Object is not in the map. Learn it.
+ //
+ cout << "New Queue: " << name << endl;
+ queueMap[oid] = name;
+ }
+ }
+
+ //
+ // Receive statistic updates from the agent.
+ //
+ void objectStats(Broker& /*broker*/, Object& object) {
+ ObjectId oid = object.getObjectId();
+ QueueMap::iterator iter = queueMap.find(oid);
+ if (iter == queueMap.end())
+ //
+ // Object id is not in the map. We are not interested in this update.
+ //
+ return;
+
+ cout << "Stats for: " << iter->second << endl;
+ cout << " msgTotalEnqueues = " << object.attrUint64("msgTotalEnqueues") << endl;
+ cout << " msgTotalDequeues = " << object.attrUint64("msgTotalDequeues") << endl;
+ cout << " msgDepth = " << object.attrUint("msgDepth") << endl;
+
+ if (object.isDeleted()) {
+ //
+ // Object was deleted and is in the map. Remove it.
+ //
+ cout << "Queue Deleted: " << iter->second << endl;
+ queueMap.erase(oid);
+ }
+
+ //
+ // Note that the object-delete logic is done after processing statistics.
+ // This allows us to get the "final" statistics for a deleted object. It also
+ // assures that very short-lived objects are accounted for (i.e. created, used,
+ // and destroyed all within a single reporting interval).
+ //
+ }
+};
+
+//==============================================================
+// Main program
+//==============================================================
+int main_int(int /*argc*/, char** /*argv*/)
+{
+ Listener listener;
+
+ //
+ // Tune the settings for this application: We wish to receive objects but not events.
+ // By using "userBindings", we can restrict which objects we receive updates for.
+ //
+ SessionManager::Settings sessionSettings;
+ sessionSettings.rcvObjects = true;
+ sessionSettings.rcvEvents = false;
+ sessionSettings.rcvHeartbeats = false;
+ sessionSettings.userBindings = true;
+
+ SessionManager sm(&listener, sessionSettings);
+
+ //
+ // We want to receive updates only for the broker queue object.
+ //
+ sm.bindClass("org.apache.qpid.broker", "queue");
+
+ //
+ // Connect to the broker.
+ //
+ qpid::client::ConnectionSettings connSettings;
+ Broker* broker = sm.addBroker(connSettings);
+
+ //
+ // Sleep while the listener does all the work asynchronously.
+ //
+ for (;;) {
+ sleep(1);
+ }
+
+ sm.delBroker(broker);
+ return 0;
+}
+
+int main(int argc, char** argv)
+{
+ try {
+ return main_int(argc, argv);
+ } catch(std::exception& e) {
+ cout << "Top Level Exception: " << e.what() << endl;
+ }
+}
+
diff --git a/qpid/cpp/src/qpid/console/SessionManager.cpp b/qpid/cpp/src/qpid/console/SessionManager.cpp
index 336f429c5d..feccf92b01 100644
--- a/qpid/cpp/src/qpid/console/SessionManager.cpp
+++ b/qpid/cpp/src/qpid/console/SessionManager.cpp
@@ -437,8 +437,8 @@ void SessionManager::handleContentInd(Broker* broker, Buffer& buffer, uint32_t s
if (syncSequenceList.count(sequence) == 1) {
if (!object.isDeleted())
getResult.push_back(object);
+ return;
}
- return;
}
if (listener) {
diff --git a/qpid/cpp/src/tests/ManagementTest.cpp b/qpid/cpp/src/tests/ManagementTest.cpp
index a3d29ec22c..e6f2e2e3fd 100644
--- a/qpid/cpp/src/tests/ManagementTest.cpp
+++ b/qpid/cpp/src/tests/ManagementTest.cpp
@@ -21,6 +21,7 @@
#include "qpid/management/ManagementObject.h"
#include "qpid/framing/Buffer.h"
+#include "qpid/console/ObjectId.h"
#include "unit_test.h"
QPID_AUTO_TEST_SUITE(ManagementTestSuite)
@@ -80,6 +81,32 @@ QPID_AUTO_TEST_CASE(testObjectIdAttach) {
BOOST_CHECK_EQUAL(out2.str(), "10-20-30-40-50");
}
+QPID_AUTO_TEST_CASE(testConsoleObjectId) {
+ qpid::console::ObjectId oid1, oid2;
+
+ oid1.setValue(1, 2);
+ oid2.setValue(3, 4);
+
+ BOOST_CHECK(oid1 < oid2);
+ BOOST_CHECK(oid1 <= oid2);
+ BOOST_CHECK(oid2 > oid1);
+ BOOST_CHECK(oid2 >= oid1);
+ BOOST_CHECK(oid1 != oid2);
+ BOOST_CHECK(oid1 == oid1);
+
+ oid1.setValue(3, 6);
+ oid2.setValue(3, 4);
+
+ BOOST_CHECK(oid1 > oid2);
+ BOOST_CHECK(oid1 >= oid2);
+ BOOST_CHECK(oid2 < oid1);
+ BOOST_CHECK(oid2 <= oid1);
+ BOOST_CHECK(oid1 != oid2);
+
+ oid2.setValue(3, 6);
+ BOOST_CHECK(oid1 == oid2);
+}
+
QPID_AUTO_TEST_SUITE_END()