summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Sim <gsim@apache.org>2008-08-07 12:45:32 +0000
committerGordon Sim <gsim@apache.org>2008-08-07 12:45:32 +0000
commitbfa30386fb3d881b3849a99fdb69ece18a19d837 (patch)
tree2ebea586cd549e697d636a4229c590bcffff49d0
parent614baa7c22a59f9f0cf9149c900b67ce0756ae26 (diff)
downloadqpid-python-bfa30386fb3d881b3849a99fdb69ece18a19d837.tar.gz
Updated suppressions
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/branches/qpid.0-10@683603 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/boost-1.32-support/main.patch189
1 files changed, 65 insertions, 124 deletions
diff --git a/cpp/boost-1.32-support/main.patch b/cpp/boost-1.32-support/main.patch
index af9b839313..7e03ff206d 100644
--- a/cpp/boost-1.32-support/main.patch
+++ b/cpp/boost-1.32-support/main.patch
@@ -1,130 +1,71 @@
Index: src/tests/.valgrind.supp
===================================================================
---- src/tests/.valgrind.supp (revision 681145)
-+++ src/tests/.valgrind.supp (working copy)
-@@ -193,8 +193,112 @@
+--- src/tests/.valgrind.supp (revision 683589)
++++ src/tests/.valgrind.supp (working copy)
+@@ -70,19 +70,6 @@
+ fun:pthread_create@@GLIBC_2.2.5
+ fun:_ZN4qpid6broker5Timer5startEv
+ fun:_ZN4qpid6broker5TimerC1Ev
+- fun:_ZN4qpid6broker10DtxManagerC1Ev
+- fun:_ZN4qpid6broker6BrokerC1ERKNS1_7OptionsE
+- fun:_ZN4qpid6broker6Broker6createERKNS1_7OptionsE
+- fun:_ZN15SessionFixtureTI15ProxyConnectionEC2Ev
+- fun:_Z14testQueueQueryv
+- fun:_ZN5boost9unit_test9ut_detail17unit_test_monitor8functionEv
+- obj:/usr/lib64/libboost_unit_test_framework.so.1.32.0
+- fun:_ZN5boost17execution_monitor7executeEbi
+- fun:_ZN5boost9unit_test9ut_detail17unit_test_monitor21execute_and_translateEPNS0_9test_caseEMS3_FvvEi
+- fun:_ZN5boost9unit_test9test_case3runEv
+- fun:_ZN5boost9unit_test10test_suite6do_runEv
+- fun:_ZN5boost9unit_test9test_case3runEv
+- fun:main
}
-
+
{
-- CPG related errors - seem benign but should invesgitate.
-+ similar to other param error, below.
- Memcheck:Param
-+ socketcall.sendto(msg)
-+ fun:send
-+ fun:get_mapping
-+}
-+
-+{
-+ RHEL4 -- we think Boost is responsible for these leaks.
-+ Memcheck:Leak
-+ fun:_Znwm
-+ fun:_ZN5boost15program_options??options_description*
-+}
-+
-+{
-+ RHEL4 -- we think Boost is responsible for these leaks.
-+ Memcheck:Leak
-+ fun:_Znwm
-+ fun:_ZN5boost9unit_test9test_case*
-+}
-+
-+{
-+ RHEL4 -- we think Boost is responsible for these leaks.
-+ Memcheck:Leak
-+ fun:calloc
-+ fun:_dlerror_run
-+ fun:dlopen@@GLIBC_2.2.5
-+ fun:_ZN4qpid3sys5Shlib4loadEPKc
-+ fun:_Z9testShlibv
-+ fun:_ZN5boost9unit_test9ut_detail17unit_test_monitor8functionEv
-+ obj:/usr/lib64/libboost_unit_test_framework.so.1.32.0
-+ fun:_ZN5boost17execution_monitor7executeEbi
-+ fun:_ZN5boost9unit_test9ut_detail17unit_test_monitor21execute_and_translateEPNS0_9test_caseEMS3_FvvEi
-+ fun:_ZN5boost9unit_test9test_case3runEv
-+ fun:_ZN5boost9unit_test10test_suite6do_runEv
-+ fun:_ZN5boost9unit_test9test_case3runEv
-+ fun:main
-+}
-+
-+{
-+ RHEL4 -- we think Boost is responsible for these leaks.
-+ Memcheck:Leak
-+ fun:calloc
-+ fun:_dl_allocate_tls
-+ fun:pthread_create@@GLIBC_2.2.5
-+ fun:_ZN4qpid6broker5Timer5startEv
-+ fun:_ZN4qpid6broker5TimerC1Ev
-+ fun:_ZN4qpid6broker10DtxManagerC1Ev
-+}
-+
-+{
-+ INVESTIGATE
-+ Memcheck:Leak
-+ fun:calloc
-+ fun:_dl_allocate_tls
-+ fun:pthread_create@@GLIBC_2.2.5
-+ fun:_ZN4qpid6client9Connector4initEv
-+ fun:_ZN4qpid6client14ConnectionImpl4openERKSsiS3_S3_S3_
-+}
-+
-+{
-+ INVESTIGATE
-+ Memcheck:Param
-+ write(buf)
-+ obj:/lib64/tls/libc-2.3.4.so
-+ fun:_ZNK4qpid3sys6Socket5writeEPKvm
-+ fun:_ZN4qpid3sys8AsynchIO9writeableERNS0_14DispatchHandleE
-+}
-+
-+{
-+ INVESTIGATE
-+ Memcheck:Leak
-+ fun:calloc
-+ fun:_dl_allocate_tls
-+ fun:pthread_create@@GLIBC_2.2.5
-+ fun:_ZN4qpid6broker5Timer5startEv
-+ fun:_ZN4qpid6broker5TimerC1Ev
-+ fun:_ZN4qpid6broker10DtxManagerC1Ev
-+}
-+{
-+ RHEL4 (and FC5)
-+ Memcheck:Leak
-+ fun:calloc
-+ fun:_dl_allocate_tls
-+ fun:pthread_create@@GLIBC_2.2.5
-+ fun:_ZN4qpid6client9Connector4initEv
-+}
-+{
-+ INVESTIGATE
-+ Memcheck:Param
-+ futex(utime)
-+ fun:__lll_mutex_unlock_wake
-+}
-+{
-+ SAME ISSUE, NEW OCCURENCE
-+ Memcheck:Leak
-+ fun:calloc
-+ fun:_dl_allocate_tls
-+ fun:pthread_create@@GLIBC_2.2.5
-+ fun:_ZN4qpid6broker5Timer5startEv
-+ fun:_ZN4qpid6broker5TimerC1Ev
-+ fun:_ZN4qpid6broker12LinkRegistryC1EPNS0_6BrokerE
-+}
-+{
-+ CPG related errors - seem benign but should invesgitate.
-+ Memcheck:Param
- socketcall.sendmsg(msg.msg_iov[i])
- fun:sendmsg
- obj:/usr/lib/openais/libcpg.so.2.0.0
+@@ -151,29 +138,6 @@
+ fun:calloc
+ fun:_dl_allocate_tls
+ fun:pthread_create@@GLIBC_2.2.5
+- fun:_ZN4qpid6broker5Timer5startEv
+- fun:_ZN4qpid6broker5TimerC1Ev
+- fun:_ZN4qpid6broker10DtxManagerC1Ev
+- fun:_ZN4qpid6broker6BrokerC1ERKNS1_7OptionsE
+- fun:_ZN4qpid6broker6Broker6createERKNS1_7OptionsE
+- fun:_ZN20ClientSessionFixtureC1Ev
+- fun:_Z14testQueueQueryv
+- fun:_ZN5boost9unit_test9ut_detail17unit_test_monitor8functionEv
+- obj:/usr/lib64/libboost_unit_test_framework.so.1.32.0
+- fun:_ZN5boost17execution_monitor7executeEbi
+- fun:_ZN5boost9unit_test9ut_detail17unit_test_monitor21execute_and_translateEPNS0_9test_caseEMS3_FvvEi
+- fun:_ZN5boost9unit_test9test_case3runEv
+- fun:_ZN5boost9unit_test10test_suite6do_runEv
+- fun:_ZN5boost9unit_test9test_case3runEv
+- fun:main
+-}
+-
+-{
+- INVESTIGATE
+- Memcheck:Leak
+- fun:calloc
+- fun:_dl_allocate_tls
+- fun:pthread_create@@GLIBC_2.2.5
+ fun:_ZN4qpid6client9Connector4initEv
+ }
+
+@@ -191,4 +155,3 @@
+ fun:strdup
+ fun:_ZN4qpid7Options5parseEiPPcRKSsb
+ }
+-
Index: configure.ac
===================================================================
---- configure.ac (revision 681145)
-+++ configure.ac (working copy)
-@@ -64,7 +64,6 @@
- # -Wunreachable-code -Wpadded -Winline
- # -Wshadow - warns about boost headers.
- if test "${enableval}" = yes; then
-- gl_COMPILER_FLAGS(-Werror)
- gl_COMPILER_FLAGS(-pedantic)
- gl_COMPILER_FLAGS(-Wall)
- gl_COMPILER_FLAGS(-Wextra)
+--- configure.ac (revision 683589)
++++ configure.ac (working copy)
+@@ -66,7 +66,6 @@
+ # -Wshadow - warns about boost headers.
+
+ if test "${enableval}" = yes; then
+- gl_COMPILER_FLAGS(-Werror)
+ gl_COMPILER_FLAGS(-pedantic)
+ gl_COMPILER_FLAGS(-Wall)
+ gl_COMPILER_FLAGS(-Wextra)