summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Sim <gsim@apache.org>2008-08-12 15:39:06 +0000
committerGordon Sim <gsim@apache.org>2008-08-12 15:39:06 +0000
commitd2fe7341a0d878824c75e29397095754522d7d81 (patch)
treee8b1ab0abcde1bf0265d99645434f37e1960148f
parent9960a6b2d103145c3fe554dc0720545dec242816 (diff)
downloadqpid-python-d2fe7341a0d878824c75e29397095754522d7d81.tar.gz
use decimal literal (python 2.3 converts the old hex literal into a negative value)
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/branches/qpid.0-10@685189 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--python/tests/spec010.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/tests/spec010.py b/python/tests/spec010.py
index b08ad5e925..df9cb9590a 100644
--- a/python/tests/spec010.py
+++ b/python/tests/spec010.py
@@ -49,7 +49,7 @@ class SpecTest(TestCase):
mp = self.spec["message.message_properties"]
rt = self.spec["message.reply_to"]
- props = Struct(mp, content_length=0xDEADBEEF,
+ props = Struct(mp, content_length=3735928559L,
reply_to=Struct(rt, exchange="the exchange name",
routing_key="the routing key"))
dec = self.encdec(mp, props)