summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2007-03-09 18:15:02 +0000
committerAlan Conway <aconway@apache.org>2007-03-09 18:15:02 +0000
commit4a19585c415851d0b308228a83b8abd55c8dc5a9 (patch)
treee0a7984bd3d7da934f1d695b2c65473d3ab950a8
parent483dd37a5decdcf489c4f1b7eaf249c314125b3a (diff)
downloadqpid-python-4a19585c415851d0b308228a83b8abd55c8dc5a9.tar.gz
Merged revisions 493126-493151 via svnmerge from
https://svn.apache.org/repos/asf/incubator/qpid/trunk/qpid ........ r493126 | aconway | 2007-01-05 13:34:08 -0500 (Fri, 05 Jan 2007) | 2 lines Add refernece to prereqs in README-dist. ........ r493140 | aconway | 2007-01-05 14:09:10 -0500 (Fri, 05 Jan 2007) | 8 lines 2007-01-05 Jim Meyering <meyering@redhat.com> * gen/Makefile.am (gen-src.mk) [CAN_GENERATE_CODE]: Emit an empty dependency for each generated file, in case they are renamed, removed, or no longer generated. Otherwise, "./bootstrap --build" would fail with e.g., `*** No rule to make target ../../gentools/templ.cpp/AMQP_HighestVersion.cpp.tmpl'. ........ r493151 | aconway | 2007-01-05 14:25:32 -0500 (Fri, 05 Jan 2007) | 6 lines 2007-01-05 Jim Meyering <meyering@redhat.com> * lib/broker/Makefile.am (libqpidbroker_la_LIBADD): Define, so we link with libqpidcommon.la. * lib/client/Makefile.am (libqpidclient_la_LIBADD): Likewise. ........ git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/branches/qpid.0-9@516489 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/README-dev8
-rw-r--r--cpp/gen/Makefile.am2
-rw-r--r--cpp/lib/broker/Makefile.am3
-rw-r--r--cpp/lib/client/Makefile.am5
4 files changed, 11 insertions, 7 deletions
diff --git a/cpp/README-dev b/cpp/README-dev
index 60c43d0ef5..37f66604f1 100644
--- a/cpp/README-dev
+++ b/cpp/README-dev
@@ -6,10 +6,12 @@ sudo cp /usr/share/aclocal/pkg.m4 `aclocal --print-ac-dir`
== Prerequisites ==
If you have taken the sources from SVN you will need the following
-packages (or later) to build Qpid. We prefer to avoid spending time
-accommodating older versions of these packages, so please make sure
-that you have the latest stable version.
+packages (or later)
+We prefer to avoid spending time accommodating older versions of these
+packages, so please make sure that you have the latest stable version.
+
+ * All the prerequisites listed in README-dist.
* GNU make <http://www.gnu.org/software/make/>
* autoconf <http://www.gnu.org/software/autoconf/>
* automake <http://www.gnu.org/software/automake/>
diff --git a/cpp/gen/Makefile.am b/cpp/gen/Makefile.am
index 796707b411..c9af573f3a 100644
--- a/cpp/gen/Makefile.am
+++ b/cpp/gen/Makefile.am
@@ -11,7 +11,7 @@ DISTCLEANFILES = $(BUILT_SOURCES) timestamp gen-src.mk
# Don't attempt to run the code generator unless configure has set
# CAN_GENERATE_CODE, indicating that the amqp.xml and tools needed
# to run the code generator are available.
-#
+#
if CAN_GENERATE_CODE
gentools_dir = $(srcdir)/../../gentools
diff --git a/cpp/lib/broker/Makefile.am b/cpp/lib/broker/Makefile.am
index 760c6d61e2..68649c2b28 100644
--- a/cpp/lib/broker/Makefile.am
+++ b/cpp/lib/broker/Makefile.am
@@ -7,8 +7,9 @@ INCLUDES = \
$(APR_CXXFLAGS)
lib_LTLIBRARIES = libqpidbroker.la
+libqpidbroker_la_LIBADD = ../common/libqpidcommon.la
libqpidbroker_la_LDFLAGS = -version-info $(LIBTOOL_VERSION_INFO_ARG)
-libqpidbroker_la_SOURCES = \
+libqpidbroker_la_SOURCES = \
AccumulatedAck.cpp \
AccumulatedAck.h \
AutoDelete.cpp \
diff --git a/cpp/lib/client/Makefile.am b/cpp/lib/client/Makefile.am
index 9f345d866d..1e10a2a244 100644
--- a/cpp/lib/client/Makefile.am
+++ b/cpp/lib/client/Makefile.am
@@ -7,8 +7,9 @@ INCLUDES = \
$(APR_CXXFLAGS)
lib_LTLIBRARIES = libqpidclient.la
+libqpidclient_la_LIBADD = ../common/libqpidcommon.la
libqpidclient_la_LDFLAGS = -version-info $(LIBTOOL_VERSION_INFO_ARG)
-libqpidclient_la_SOURCES = \
+libqpidclient_la_SOURCES = \
ClientChannel.cpp \
ClientExchange.cpp \
ClientMessage.cpp \
@@ -20,7 +21,7 @@ libqpidclient_la_SOURCES = \
MessageListener.cpp \
ResponseHandler.cpp \
ReturnedMessageHandler.cpp
-pkginclude_HEADERS = \
+pkginclude_HEADERS = \
ClientChannel.h \
ClientExchange.h \
ClientMessage.h \