summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2007-03-09 16:51:47 +0000
committerAlan Conway <aconway@apache.org>2007-03-09 16:51:47 +0000
commitd76a43d243a10cd3de996edd9436ac9104039287 (patch)
tree1c44f5a1e3eb88e0628f9752d7b34fd3217e8576
parentd44dcf7c41c2fb35854bf2542a390dd800facdfa (diff)
downloadqpid-python-d76a43d243a10cd3de996edd9436ac9104039287.tar.gz
Merged revisions 492636 via svnmerge from
https://svn.apache.org/repos/asf/incubator/qpid/trunk/qpid ........ r492636 | aconway | 2007-01-04 11:55:03 -0500 (Thu, 04 Jan 2007) | 3 lines Added "make check" to -build flag. Removed rpm build directories from svn. Create them during make. ........ git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/branches/qpid.0-9@516459 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/rpm/Makefile.am15
1 files changed, 5 insertions, 10 deletions
diff --git a/cpp/rpm/Makefile.am b/cpp/rpm/Makefile.am
index 887b3112c6..3149e26591 100644
--- a/cpp/rpm/Makefile.am
+++ b/cpp/rpm/Makefile.am
@@ -10,22 +10,17 @@ RPMOPTS=--define "_sourcedir ${abs_top_srcdir}" --define "_topdir ${abs_builddir
clean:
rm -rf BUILD RPMS SOURCES SPECS SRPMS
-.PHONY: rpm srpm dist dirs
+.PHONY: rpm srpm dist
# Build source and binary RPMs.
-rpm: dist dirs
+rpm: dist
rpmbuild $(RPMOPTS) -ba $(SPEC)
# Source RPM only.
-srpm: dist dirs
+srpm: dist
rpmbuild $(RPMOPTS) -bs $(SPEC)
-# Build source distribution.
+# Build source distribution and create required subdirs.
dist:
cd .. && $(MAKE) $(AM_MAKEFLAGS) dist
-
-# Create build directories.
-dirs: BUILD RPMS SOURCES SPECS SRPMS
-BUILD RPMS SOURCES SPECS SRPMS:
- $(MKDIR_P) BUILD RPMS SOURCES SPECS SRPMS
-
+ mkdir -p BUILD RPMS SOURCES SPECS SRPMS