summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2007-03-14 17:47:47 +0000
committerAlan Conway <aconway@apache.org>2007-03-14 17:47:47 +0000
commitf2267058916ef0ee8bdc1913cfe96a36e90145e5 (patch)
treee563de3da8b4d56ef964013cf65cf96076ca35d6
parente358fe4d41a0f5c38d0a9133ab3e4a709698bda9 (diff)
downloadqpid-python-f2267058916ef0ee8bdc1913cfe96a36e90145e5.tar.gz
Merged revisions 507455 via svnmerge from
https://svn.apache.org/repos/asf/incubator/qpid/trunk/qpid ........ r507455 | gsim | 2007-02-14 04:46:08 -0500 (Wed, 14 Feb 2007) | 8 lines Applied patch from Jim Meyering, submitted on dev list: 2007-02-14 Jim Meyering <jim@meyering.net> * configure.ac: Use $enableval, not $enable_APR in the code supporting --disable-apr and --enable-apr. The latter doesn't work. ........ git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/branches/qpid.0-9@518236 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/cpp/configure.ac b/cpp/configure.ac
index 58596a91c0..1e6cf3fdb6 100644
--- a/cpp/configure.ac
+++ b/cpp/configure.ac
@@ -103,18 +103,18 @@ AC_SUBST(CPPUNIT_CXXFLAGS)
AC_ARG_ENABLE(apr,
[ --enable-apr use the Apache Portable Runtime library (default)
--disable-apr do not use the Apache Portable Runtime library],
-[case $enable_APR in
+[case $enableval in
yes|no) ;;
- *) AC_MSG_ERROR([invalid APR enable/disable value: $enable_APR]) ;;
+ *) AC_MSG_ERROR([invalid APR enable/disable value: $enableval]) ;;
esac],
-[enable_APR=yes])
+[enableval=yes])
APR_MINIMUM_VERSION=1.2.2
AC_SUBST(APR_MINIMUM_VERSION)
AC_SUBST(APR_CXXFLAGS)
AC_SUBST(USE_APR)
-if test "$enable_APR" = yes; then
+if test "$enableval" = yes; then
PKG_CHECK_MODULES([APR], [apr-1 >= $APR_MINIMUM_VERSION])
APR_CXXFLAGS="$APR_CFLAGS -DUSE_APR=1"
USE_APR=1