summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2008-08-18 18:52:39 +0000
committerAlan Conway <aconway@apache.org>2008-08-18 18:52:39 +0000
commitfe569210176b355cc161561160ec8b2b23920919 (patch)
treeb5b9a811ad7d8ad0cfc4b1fc322cb8db579b7bf6
parentb0edfc1f74ecb304390a1bfffc467f125d4bbf20 (diff)
downloadqpid-python-fe569210176b355cc161561160ec8b2b23920919.tar.gz
Configure --without-cpg by default for M3.
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk/qpid@686846 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/cpp/configure.ac b/cpp/configure.ac
index 1aa0a6fe63..5e478c68cf 100644
--- a/cpp/configure.ac
+++ b/cpp/configure.ac
@@ -175,14 +175,12 @@ AC_ARG_WITH([cpg],
no) with_CPG=no ;;
*) AC_MSG_ERROR([Bad value ${withval} for --with-cpg option]) ;;
esac],
- [ # not specified - enable if libs/headers available.
- with_CPG=yes
- AC_CHECK_LIB([cpg],[cpg_local_get],,[with_CPG=no])
- AC_CHECK_HEADERS([openais/cpg.h],,[with_CPG=no])
+ [ # not specified - default no
+ with_CPG=no
]
)
-# Remove from LIBS, we will link it explicitly in make files.
LIBS=$tmp_LIBS
+
AM_CONDITIONAL([CPG], [test x$with_CPG = xyes])
if test x$with_CPG = xyes; then
CPPFLAGS+=" -DCPG"