summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Sim <gsim@apache.org>2009-12-15 08:23:19 +0000
committerGordon Sim <gsim@apache.org>2009-12-15 08:23:19 +0000
commit3baba3c1462930d78662492e0a083d63822b33d0 (patch)
tree412c45945a7e143124f1f1f59aae9dd054484a49
parent779f9c990d4053c7401f39abcddfabd354de68af (diff)
downloadqpid-python-3baba3c1462930d78662492e0a083d63822b33d0.tar.gz
QPID-2212: revert previous attempt at fix; disable on windows only
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk/qpid@890683 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/examples/messaging/CMakeLists.txt10
-rw-r--r--cpp/include/qpid/sys/ExceptionHolder.h (renamed from cpp/src/qpid/sys/ExceptionHolder.h)1
-rw-r--r--cpp/src/Makefile.am2
3 files changed, 7 insertions, 6 deletions
diff --git a/cpp/examples/messaging/CMakeLists.txt b/cpp/examples/messaging/CMakeLists.txt
index 7c023e602a..88ab81dae9 100644
--- a/cpp/examples/messaging/CMakeLists.txt
+++ b/cpp/examples/messaging/CMakeLists.txt
@@ -17,10 +17,12 @@
# under the License.
#
-# disabling spout & drain under cmake until build issues on windows
-# are resolved (QPID-2212):
-#add_example(messaging drain ${Boost_PROGRAM_OPTIONS_LIBRARY})
-#add_example(messaging spout ${Boost_PROGRAM_OPTIONS_LIBRARY})
+# disabling spout & drain on windows until build issues are resolved
+# (QPID-2212):
+if (NOT MSVC)
+ add_example(messaging drain)
+ add_example(messaging spout)
+endif (NOT MSVC)
add_example(messaging queue_receiver)
add_example(messaging queue_sender)
diff --git a/cpp/src/qpid/sys/ExceptionHolder.h b/cpp/include/qpid/sys/ExceptionHolder.h
index fecaa73eea..9eff1d64c7 100644
--- a/cpp/src/qpid/sys/ExceptionHolder.h
+++ b/cpp/include/qpid/sys/ExceptionHolder.h
@@ -22,7 +22,6 @@
*
*/
-#include "qpid/memory.h"
#include <boost/shared_ptr.hpp>
diff --git a/cpp/src/Makefile.am b/cpp/src/Makefile.am
index ee2acb673b..9adbbb6bf6 100644
--- a/cpp/src/Makefile.am
+++ b/cpp/src/Makefile.am
@@ -444,7 +444,6 @@ libqpidcommon_la_SOURCES += \
qpid/sys/DispatchHandle.h \
qpid/sys/Dispatcher.cpp \
qpid/sys/Dispatcher.h \
- qpid/sys/ExceptionHolder.h \
qpid/sys/FileSysDir.h \
qpid/sys/Fork.h \
qpid/sys/LockFile.h \
@@ -791,6 +790,7 @@ nobase_include_HEADERS += \
../include/qpid/management/ManagementEvent.h \
../include/qpid/management/ManagementObject.h \
../include/qpid/sys/Condition.h \
+ ../include/qpid/sys/ExceptionHolder.h \
../include/qpid/sys/IOHandle.h \
../include/qpid/sys/IntegerTypes.h \
../include/qpid/sys/Monitor.h \