summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen D. Huston <shuston@apache.org>2009-12-04 02:26:16 +0000
committerStephen D. Huston <shuston@apache.org>2009-12-04 02:26:16 +0000
commit716dedd48f5ee0d6f5640d4850ec7f273f5e91d9 (patch)
tree3f21799bbf4026ac72ae4a17d10b982700431f60
parent43f0dea566c81bb72aea75b825bbd97ec5d1d950 (diff)
downloadqpid-python-716dedd48f5ee0d6f5640d4850ec7f273f5e91d9.tar.gz
Fix build errors in test_store; resolves QPID-2229
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk/qpid@887038 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/src/tests/CMakeLists.txt1
-rw-r--r--cpp/src/tests/test_store.cpp9
2 files changed, 5 insertions, 5 deletions
diff --git a/cpp/src/tests/CMakeLists.txt b/cpp/src/tests/CMakeLists.txt
index 1d67d22e7c..43f92b2d2d 100644
--- a/cpp/src/tests/CMakeLists.txt
+++ b/cpp/src/tests/CMakeLists.txt
@@ -290,6 +290,7 @@ endif (BUILD_ACL)
endif (PYTHON_EXECUTABLE)
add_library(test_store MODULE test_store.cpp)
+target_link_libraries (test_store qpidbroker qpidcommon)
set_target_properties (test_store PROPERTIES PREFIX "")
#EXTRA_DIST += \
diff --git a/cpp/src/tests/test_store.cpp b/cpp/src/tests/test_store.cpp
index f2d3aa65a3..c675c6daa3 100644
--- a/cpp/src/tests/test_store.cpp
+++ b/cpp/src/tests/test_store.cpp
@@ -43,7 +43,6 @@
using namespace qpid;
using namespace broker;
using namespace std;
-using namespace boost;
using namespace qpid::sys;
namespace qpid {
@@ -60,9 +59,9 @@ struct TestStoreOptions : public Options {
};
struct Completer : public Runnable {
- intrusive_ptr<PersistableMessage> message;
+ boost::intrusive_ptr<PersistableMessage> message;
int usecs;
- Completer(intrusive_ptr<PersistableMessage> m, int u) : message(m), usecs(u) {}
+ Completer(boost::intrusive_ptr<PersistableMessage> m, int u) : message(m), usecs(u) {}
void run() {
qpid::sys::usleep(usecs);
message->enqueueComplete();
@@ -82,7 +81,7 @@ class TestStore : public NullMessageStore {
const boost::intrusive_ptr<PersistableMessage>& msg,
const PersistableQueue& )
{
- string data = polymorphic_downcast<Message*>(msg.get())->getFrames().getContent();
+ string data = boost::polymorphic_downcast<Message*>(msg.get())->getFrames().getContent();
// Check the message for special instructions.
size_t i = string::npos;
@@ -106,7 +105,7 @@ class TestStore : public NullMessageStore {
}
else if (strncmp(action.c_str(), ASYNC.c_str(), strlen(ASYNC.c_str())) == 0) {
std::string delayStr(action.substr(ASYNC.size()));
- int delay = lexical_cast<int>(delayStr);
+ int delay = boost::lexical_cast<int>(delayStr);
threads.push_back(Thread(*new Completer(msg, delay)));
}
else {