summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen D. Huston <shuston@apache.org>2009-12-15 17:07:13 +0000
committerStephen D. Huston <shuston@apache.org>2009-12-15 17:07:13 +0000
commitfed2f28574fe4ce34de0ec674914416ba16f2956 (patch)
treeba956f53c77029883713cc987904b09300a39bc1
parent17450dde553efb74e549493391288af5ee2b6e3b (diff)
downloadqpid-python-fed2f28574fe4ce34de0ec674914416ba16f2956.tar.gz
The spout/drain examples have qpid::Options usage which inlines the boost::program_options usage. This requires linking boost_program_options in the examples, not via qpidcommon. Adjust the Windows options to handle this. Resolves QPID-2212.
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk/qpid@890888 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/examples/CMakeLists.txt4
-rw-r--r--cpp/examples/messaging/CMakeLists.txt10
2 files changed, 5 insertions, 9 deletions
diff --git a/cpp/examples/CMakeLists.txt b/cpp/examples/CMakeLists.txt
index de74d9cf39..7ecffed4bb 100644
--- a/cpp/examples/CMakeLists.txt
+++ b/cpp/examples/CMakeLists.txt
@@ -39,13 +39,11 @@ link_directories( ${Boost_LIBRARY_DIRS} )
# resolved via the Qpid libs.
if (MSVC)
add_definitions( /D "NOMINMAX" /D "WIN32_LEAN_AND_MEAN" /D "BOOST_ALL_DYN_LINK" )
- set(Boost_PROGRAM_OPTIONS_LIBRARY "")
- set(Boost_FILESYSTEM_LIBRARY "")
# On Windows, prevent the accidental inclusion of Boost headers from
# autolinking in the Boost libs. There should be no direct references to
# Boost in the examples, and references via qpidclient/qpidcommon are
# resolved in the Qpid libs.
- add_definitions( /D "BOOST_ALL_DYN_LINK" /D "BOOST_ALL_NO_LIB" )
+ add_definitions( /D "BOOST_ALL_NO_LIB" )
else (MSVC)
set(_boost_libs_needed ${Boost_PROGRAM_OPTIONS_LIBRARY}
${Boost_FILESYSTEM_LIBRARY})
diff --git a/cpp/examples/messaging/CMakeLists.txt b/cpp/examples/messaging/CMakeLists.txt
index 88ab81dae9..b2b2bc3e43 100644
--- a/cpp/examples/messaging/CMakeLists.txt
+++ b/cpp/examples/messaging/CMakeLists.txt
@@ -17,12 +17,10 @@
# under the License.
#
-# disabling spout & drain on windows until build issues are resolved
-# (QPID-2212):
-if (NOT MSVC)
- add_example(messaging drain)
- add_example(messaging spout)
-endif (NOT MSVC)
+# drain and spout have explicit Boost.program_options usage in them, so be
+# sure that lib is linked in.
+add_example(messaging drain ${Boost_PROGRAM_OPTIONS_LIBRARY})
+add_example(messaging spout ${Boost_PROGRAM_OPTIONS_LIBRARY})
add_example(messaging queue_receiver)
add_example(messaging queue_sender)