summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArnaud Simon <arnaudsimon@apache.org>2008-01-18 10:36:50 +0000
committerArnaud Simon <arnaudsimon@apache.org>2008-01-18 10:36:50 +0000
commit70f2437cc12aa48958a0ff3f7a1d59ce29a5eb47 (patch)
treee3e8c9f4c0806ad304472fe2f1b54c5152819eac
parentf1322e3e4a41c1282ac7daf3a8b0764beb7cea1b (diff)
downloadqpid-python-70f2437cc12aa48958a0ff3f7a1d59ce29a5eb47.tar.gz
Qpid-745
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@613126 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/python/examples/direct/declare_queues.py6
-rw-r--r--qpid/python/examples/direct/listener.py4
-rw-r--r--qpid/python/examples/fanout/declare_queues.py5
-rw-r--r--qpid/python/examples/fanout/fanout_consumer.py6
-rw-r--r--qpid/python/examples/fanout/fanout_producer.py2
-rw-r--r--qpid/python/examples/fanout/listener.py6
-rw-r--r--qpid/python/examples/pubsub/topic_subscriber.py4
-rw-r--r--qpid/python/examples/request-response/client.py2
-rw-r--r--qpid/python/examples/request-response/server.py2
9 files changed, 16 insertions, 21 deletions
diff --git a/qpid/python/examples/direct/declare_queues.py b/qpid/python/examples/direct/declare_queues.py
index e64ad678b8..0160f66a1d 100644
--- a/qpid/python/examples/direct/declare_queues.py
+++ b/qpid/python/examples/direct/declare_queues.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
"""
- config_direct_exchange.py
+ declare_queues.py
Creates and binds a queue on an AMQP direct exchange.
@@ -33,9 +33,6 @@ session.session_open()
#----- Create a queue -------------------------------------
-# Create a queue named "listener" on channel 1, and bind it
-# to the "amq.direct" exchange.
-#
# queue_declare() creates an AMQP queue, which is held
# on the broker. Published messages are sent to the AMQP queue,
# from which messages are delivered to consumers.
@@ -51,3 +48,4 @@ session.queue_bind(exchange="amq.direct", queue="message_queue", routing_key="ro
session.session_close()
+
diff --git a/qpid/python/examples/direct/listener.py b/qpid/python/examples/direct/listener.py
index e5eee72637..8324cc76a6 100644
--- a/qpid/python/examples/direct/listener.py
+++ b/qpid/python/examples/direct/listener.py
@@ -64,9 +64,9 @@ session.session_open()
consumer_tag = "consumer1"
queue = client.queue(consumer_tag)
-# Call message_consume() to tell the broker to deliver messages
+# Call message_subscribe() to tell the broker to deliver messages
# from the AMQP queue to this local client queue. The broker will
-# start delivering messages as soon as message_consume() is called.
+# start delivering messages as soon as message_subscribe() is called.
session.message_subscribe(queue="message_queue", destination=consumer_tag)
session.message_flow(consumer_tag, 0, 0xFFFFFFFF) # Kill these?
diff --git a/qpid/python/examples/fanout/declare_queues.py b/qpid/python/examples/fanout/declare_queues.py
index 3315f5bc14..8840ea38e1 100644
--- a/qpid/python/examples/fanout/declare_queues.py
+++ b/qpid/python/examples/fanout/declare_queues.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
"""
- config_direct_exchange.py
+ declare_queues.py
Creates and binds a queue on an AMQP direct exchange.
@@ -33,9 +33,6 @@ session.session_open()
#----- Create a queue -------------------------------------
-# Create a queue named "listener" on channel 1, and bind it
-# to the "amq.fanout" exchange.
-#
# queue_declare() creates an AMQP queue, which is held
# on the broker. Published messages are sent to the AMQP queue,
# from which messages are delivered to consumers.
diff --git a/qpid/python/examples/fanout/fanout_consumer.py b/qpid/python/examples/fanout/fanout_consumer.py
index e9a2291f4c..8d852ca753 100644
--- a/qpid/python/examples/fanout/fanout_consumer.py
+++ b/qpid/python/examples/fanout/fanout_consumer.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
"""
- direct_consumer.py
+ fanout_consumer.py
This AMQP client reads messages from a message
queue named "message_queue".
@@ -40,9 +40,9 @@ session.session_open()
consumer_tag = "consumer1"
queue = client.queue(consumer_tag)
-# Call message_consume() to tell the broker to deliver messages
+# Call message_subscribe() to tell the broker to deliver messages
# from the AMQP queue to this local client queue. The broker will
-# start delivering messages as soon as message_consume() is called.
+# start delivering messages as soon as message_subscribe() is called.
session.message_subscribe(queue="message_queue", destination=consumer_tag)
session.message_flow(consumer_tag, 0, 0xFFFFFFFF)
diff --git a/qpid/python/examples/fanout/fanout_producer.py b/qpid/python/examples/fanout/fanout_producer.py
index 92ca7b7ec0..d9d8f454c8 100644
--- a/qpid/python/examples/fanout/fanout_producer.py
+++ b/qpid/python/examples/fanout/fanout_producer.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
"""
- direct_producer.py
+ fanout_producer.py
Publishes messages to an AMQP direct exchange, using
the routing key "routing_key"
diff --git a/qpid/python/examples/fanout/listener.py b/qpid/python/examples/fanout/listener.py
index 4779466fd9..09dd7ddb80 100644
--- a/qpid/python/examples/fanout/listener.py
+++ b/qpid/python/examples/fanout/listener.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
"""
- direct_consumer.py
+ listener.py
This AMQP client reads messages from a message
queue named "message_queue".
@@ -63,9 +63,9 @@ session.session_open()
consumer_tag = "consumer1"
queue = client.queue(consumer_tag)
-# Call message_consume() to tell the broker to deliver messages
+# Call message_subscribe() to tell the broker to deliver messages
# from the AMQP queue to this local client queue. The broker will
-# start delivering messages as soon as message_consume() is called.
+# start delivering messages as soon as message_subscribe() is called.
session.message_subscribe(queue="message_queue", destination=consumer_tag)
session.message_flow(consumer_tag, 0, 0xFFFFFFFF) # Kill these?
diff --git a/qpid/python/examples/pubsub/topic_subscriber.py b/qpid/python/examples/pubsub/topic_subscriber.py
index 08682f0674..52ec67b77c 100644
--- a/qpid/python/examples/pubsub/topic_subscriber.py
+++ b/qpid/python/examples/pubsub/topic_subscriber.py
@@ -22,9 +22,9 @@ def dump_queue(client, queue_name):
consumer_tag = queue_name # Use the queue name as the consumer tag - need a unique tag
queue = client.queue(consumer_tag)
- # Call basic_consume() to tell the broker to deliver messages
+ # Call message_subscribe() to tell the broker to deliver messages
# from the AMQP queue to a local client queue. The broker will
- # start delivering messages as soon as basic_consume() is called.
+ # start delivering messages as soon as message_subscribe() is called.
session.message_subscribe(queue=queue_name, destination=consumer_tag)
session.message_flow(consumer_tag, 0, 0xFFFFFFFF)
diff --git a/qpid/python/examples/request-response/client.py b/qpid/python/examples/request-response/client.py
index bc0cf8a55a..e218acce3d 100644
--- a/qpid/python/examples/request-response/client.py
+++ b/qpid/python/examples/request-response/client.py
@@ -24,7 +24,7 @@ def dump_queue(client, queue_name):
# Call message_subscribe() to tell the broker to deliver messages
# from the AMQP queue to a local client queue. The broker will
- # start delivering messages as soon as basic_consume() is called.
+ # start delivering messages as soon as message_subscribe() is called.
session.message_subscribe(queue=queue_name, destination=consumer_tag)
session.message_flow(consumer_tag, 0, 0xFFFFFFFF)
diff --git a/qpid/python/examples/request-response/server.py b/qpid/python/examples/request-response/server.py
index 28bfd5ee4a..2730768a91 100644
--- a/qpid/python/examples/request-response/server.py
+++ b/qpid/python/examples/request-response/server.py
@@ -38,7 +38,7 @@ password="guest"
client = Client(host, port, qpid.spec.load(amqp_spec))
client.start({"LOGIN": user, "PASSWORD": password})
-# Open Channel 1 so we can use it to manage our queue.
+# Create a session and open it.
session = client.session()
session.session_open()