summaryrefslogtreecommitdiff
path: root/cpp/src/cluster.mk
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2008-09-11 13:26:10 +0000
committerAlan Conway <aconway@apache.org>2008-09-11 13:26:10 +0000
commit6c24486bbc4ffcf8c70e7d0fbac846512c83b440 (patch)
treebf7543286e7b3ff90810b01b77dacc18d3dfb638 /cpp/src/cluster.mk
parentb55c7f2d8fa39b358b8a7fbf400db5fbc71335dd (diff)
downloadqpid-python-6c24486bbc4ffcf8c70e7d0fbac846512c83b440.tar.gz
Moved PollableCondition, PollableQueue and to sys. Fixed cluster shutdown issues.
sys/PollableCondition: is a generic mechansim to poll for non-IO events in the Poller. sys/PollableQueue: is a thread-safe queue template that can be dispatched from the Poller when there are items on the queue. It uses PollableCondition. git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk/qpid@694243 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'cpp/src/cluster.mk')
-rw-r--r--cpp/src/cluster.mk3
1 files changed, 0 insertions, 3 deletions
diff --git a/cpp/src/cluster.mk b/cpp/src/cluster.mk
index bb9546f387..f02e5e1644 100644
--- a/cpp/src/cluster.mk
+++ b/cpp/src/cluster.mk
@@ -18,9 +18,6 @@ cluster_la_SOURCES = \
qpid/cluster/Connection.h \
qpid/cluster/Connection.cpp \
qpid/cluster/NoOpConnectionOutputHandler.h \
- qpid/cluster/PollableCondition.h \
- qpid/cluster/PollableCondition.cpp \
- qpid/cluster/PollableQueue.h \
qpid/cluster/WriteEstimate.h \
qpid/cluster/WriteEstimate.cpp \
qpid/cluster/OutputInterceptor.h \