summaryrefslogtreecommitdiff
path: root/cpp/src/tests/linearstore/CMakeLists.txt
diff options
context:
space:
mode:
authorKim van der Riet <kpvdr@apache.org>2014-09-16 13:47:02 +0000
committerKim van der Riet <kpvdr@apache.org>2014-09-16 13:47:02 +0000
commit58445eab763b395dca457de8e49d1f425a77daa5 (patch)
treedb7c68d0f6a67f5020dd63d71a6155f54cb3e56b /cpp/src/tests/linearstore/CMakeLists.txt
parent03c8f2a4422f3c33f3a9e09ed9ff93e87fb29da1 (diff)
downloadqpid-python-58445eab763b395dca457de8e49d1f425a77daa5.tar.gz
QPID-5361: No tests for linearstore functionality currently exist - basic tests from the legacystore suite ported to linearstore
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk/qpid@1625283 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'cpp/src/tests/linearstore/CMakeLists.txt')
-rw-r--r--cpp/src/tests/linearstore/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/cpp/src/tests/linearstore/CMakeLists.txt b/cpp/src/tests/linearstore/CMakeLists.txt
new file mode 100644
index 0000000000..996a8c63c1
--- /dev/null
+++ b/cpp/src/tests/linearstore/CMakeLists.txt
@@ -0,0 +1,29 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+if(BUILD_LINEARSTORE AND BUILD_TESTING)
+
+message(STATUS "Building linearstore tests")
+
+set(test_wrap ${shell} ${CMAKE_SOURCE_DIR}/src/tests/run_test${test_script_suffix} --build-dir=${CMAKE_BINARY_DIR})
+
+add_test (linearstore_python_tests ${test_wrap} -- ${CMAKE_CURRENT_SOURCE_DIR}/run_python_tests${test_script_suffix})
+
+endif (BUILD_LINEARSTORE AND BUILD_TESTING)
+