summaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorRafael H. Schloming <rhs@apache.org>2010-06-15 14:13:15 +0000
committerRafael H. Schloming <rhs@apache.org>2010-06-15 14:13:15 +0000
commit12785d64955afa6809e9f76ee7eb68724101c6e7 (patch)
tree21b24916721ec96d74d106551d9664189741868b /python
parentb96ff8258cb248717addd9855333e499d301bcfd (diff)
downloadqpid-python-12785d64955afa6809e9f76ee7eb68724101c6e7.tar.gz
fix for python 2.3
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk/qpid@954901 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'python')
-rw-r--r--python/qpid/ops.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/python/qpid/ops.py b/python/qpid/ops.py
index 8c9f8a03e7..390552be6d 100644
--- a/python/qpid/ops.py
+++ b/python/qpid/ops.py
@@ -25,10 +25,12 @@ class Primitive(object):
class Enum(object):
# XXX: for backwards compatibility
- @classmethod
def values(cls):
print >> sys.stderr, "warning, please use .VALUES instead of .values()"
return cls.VALUES
+ # we can't use the backport preprocessor here because this code gets
+ # called by setup.py
+ values = classmethod(values)
class Field: