summaryrefslogtreecommitdiff
path: root/qpid/cpp/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2009-04-28 21:51:54 +0000
committerAndrew Stitcher <astitcher@apache.org>2009-04-28 21:51:54 +0000
commitd003b6fde86d23727f1b77a4856f786354ea3288 (patch)
treebda2a71c1f70b41c1c48615b4d187ab855c6d46a /qpid/cpp/CMakeLists.txt
parent9231b44bd2e7843d4b44f4ef5aac8ae5f6e399af (diff)
downloadqpid-python-d003b6fde86d23727f1b77a4856f786354ea3288.tar.gz
Fixed to allow use of cmake 2.4
Fixes to allow cmake to build all the plugin modules as before git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@769559 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/CMakeLists.txt')
-rw-r--r--qpid/cpp/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/qpid/cpp/CMakeLists.txt b/qpid/cpp/CMakeLists.txt
index 9d561943bf..522d54dd39 100644
--- a/qpid/cpp/CMakeLists.txt
+++ b/qpid/cpp/CMakeLists.txt
@@ -17,7 +17,11 @@
# under the License.
#
project(qpidc)
-cmake_minimum_required(VERSION 2.6.0 FATAL_ERROR)
+cmake_minimum_required(VERSION 2.4.0 FATAL_ERROR)
+if(COMMAND cmake_policy)
+ cmake_policy(SET CMP0003 NEW)
+endif(COMMAND cmake_policy)
+
set (qpidc_version 0.5)
enable_testing()