summaryrefslogtreecommitdiff
path: root/qpid/cpp/bootstrap
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2007-04-14 16:38:02 +0000
committerAlan Conway <aconway@apache.org>2007-04-14 16:38:02 +0000
commit1b3168902f3e3c03288860e55ba02e5200606cff (patch)
tree1d7215ec8a0c762d86104df93acb62d18d8da0db /qpid/cpp/bootstrap
parentf50d67546eda00e1b0ea875ea4043770405ce7b6 (diff)
downloadqpid-python-1b3168902f3e3c03288860e55ba02e5200606cff.tar.gz
* Moved code generation into top-level gen/ dir with own Makefile.am
to correctly install generated headers. * Fixed gen-src.mk/Makefile dependency loop, bootstrap no longer needs to pre-create gen-src.mk. git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@528835 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/bootstrap')
-rwxr-xr-xqpid/cpp/bootstrap10
1 files changed, 0 insertions, 10 deletions
diff --git a/qpid/cpp/bootstrap b/qpid/cpp/bootstrap
index 55bb6152a1..d911a3bfd1 100755
--- a/qpid/cpp/bootstrap
+++ b/qpid/cpp/bootstrap
@@ -12,16 +12,6 @@ export JAVA JAVAC
# If we're building in the qpid tree, we can generate
# some Makefile snippets:
-if test -d ../specs; then
- # Transform gen/Makefile.am, removing automake-constructs and the
- # contents of the sole automake-else clause (the warning), then
- # use the result to run the rules that create gen-src.mk, a file
- # that must be created before we run automake.
- (cd src && rm -f gen/gen-src.mk
- perl -ne '/warning:|^(if|else|endif|include)\b/ or print' Makefile.am \
- | make -f - srcdir=. gen/gen-src.mk > /dev/null )
-fi
-
# Generate (for automake) lots of repetitive parts of tests/Makefile.am.
(cd src/tests && rm -f gen.mk
perl -ne '/^include / or print' Makefile.am \