summaryrefslogtreecommitdiff
path: root/qpid/cpp/bootstrap
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2007-03-21 02:05:56 +0000
committerAlan Conway <aconway@apache.org>2007-03-21 02:05:56 +0000
commit732544fe86089ab86c03fcc48d5ca4c72667c275 (patch)
treedd2ee2d8872f69b6f297ef39b0a84b95bddf4b77 /qpid/cpp/bootstrap
parent698283620afcb267bda2752b746c3e19641150ef (diff)
downloadqpid-python-732544fe86089ab86c03fcc48d5ca4c72667c275.tar.gz
* cpp: svn removed, will rename cpp-0-9
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@520705 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/bootstrap')
-rwxr-xr-xqpid/cpp/bootstrap37
1 files changed, 0 insertions, 37 deletions
diff --git a/qpid/cpp/bootstrap b/qpid/cpp/bootstrap
deleted file mode 100755
index c566d357e6..0000000000
--- a/qpid/cpp/bootstrap
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-set -e
-aclocal -I m4
-autoheader
-libtoolize --automake
-
-# These are needed only if you don't already have the gen/*.{h,cpp} files.
-: ${JAVA=java}
-: ${JAVAC=javac}
-export JAVA JAVAC
-
-# If we're building in the qpid tree, we can generate
-# some Makefile snippets:
-
-if test -d ../gentools && test -d ../specs; then
- # Transform gen/Makefile.am, removing automake-constructs and the
- # contents of the sole automake-else clause (the warning), then
- # use the result to run the rules that create gen-src.mk, a file
- # that must be created before we run automake.
- (cd gen && rm -f gen-src.mk
- perl -ne '/warning:|^(if|else|endif|include)\b/ or print' Makefile.am \
- | make -f - srcdir=. gen-src.mk > /dev/null )
-fi
-
-# Generate (for automake) lots of repetitive parts of tests/Makefile.am.
-(cd tests && rm -f gen.mk
- perl -ne '/^include / or print' Makefile.am \
- | make -f - abs_srcdir=`dirname $(pwd)` gen.mk > /dev/null )
-
-automake
-autoconf
-
-if [ "$1" = "-build" -o "$1" = "--build" ] ; then
- ./configure
- make
- make check
-fi