summaryrefslogtreecommitdiff
path: root/qpid/cpp/qpid-autotools-install
diff options
context:
space:
mode:
authorGordon Sim <gsim@apache.org>2007-01-23 15:12:27 +0000
committerGordon Sim <gsim@apache.org>2007-01-23 15:12:27 +0000
commite9014260de233fc56863e45d445a4d28d59e8fe7 (patch)
tree423b7a3437020b163e972a3fe45f28db21341d10 /qpid/cpp/qpid-autotools-install
parentbe7867b6872e8eecfd27790afc974cf592ba2475 (diff)
downloadqpid-python-e9014260de233fc56863e45d445a4d28d59e8fe7.tar.gz
Patch from Jim Meyering (jim@meyering.net) submitted on dev list.
Instrument all tests so that they are run via valgrind: check for both errors and leaks. * configure.ac: Add new configure options: --enable-valgrind and --disable-valgrind. For now, the latter is the default. * README-dev: Document (and recommend) --enable-valgrind. * tests/.vg-supp: Add many more, from Gordon Sim for FC5. * configure.ac: Check for valgrind. * tests/Makefile.am (TESTS_ENVIRONMENT): Export VALGRIND. * tests/setup: New file. * tests/run-unit-tests: Use new "setup" file. Invoke DllPlugInTester via $vg (aka valgrind). Refer to the source directory using $pwd, since we're now running from a temporary subdirectory. * tests/run-python-tests: Remove traps. That is now done by "setup". [VERBOSE]: Print qpidd --version. Invoke qpidd via $vg and its absolute name. Add a kludgey "sleep 3", because it can take a while for libtool to start valgrind to start qpidd, in the background. Ideally, the python script would simply sleep-0.3-and-retry for a couple seconds, upon failure of the initial connection attempt. * tests/.vg-supp: New file, exempting known leaks on Debian/unstable. Some of these leaks appear to be legitimate. * tests/Makefile.am (EXTRA_DIST): Add .vg-supp and setup. * qpid-autotools-install (usage): Add a missing backslash. Fix "make distcheck" failure. * docs/api/Makefile.am (EXTRA_DIST): Add user.doxygen git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@499049 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/qpid-autotools-install')
-rwxr-xr-xqpid/cpp/qpid-autotools-install4
1 files changed, 2 insertions, 2 deletions
diff --git a/qpid/cpp/qpid-autotools-install b/qpid/cpp/qpid-autotools-install
index 796f123ea0..2ed3174903 100755
--- a/qpid/cpp/qpid-autotools-install
+++ b/qpid/cpp/qpid-autotools-install
@@ -1,7 +1,7 @@
#!/bin/sh
# Written by Jim Meyering
-VERSION='2006-12-18 16:16' # UTC
+VERSION='2007-01-22 19:38' # UTC
prog_name=`basename $0`
die () { echo "$prog_name: $*" >&2; exit 1; }
@@ -24,7 +24,7 @@ Options:
--skip-check do not run "make check" (this can save 50+ min)
--help display this help and exit
-For example, to install programs into $HOME/qpid-tools/bin, run this command:
+For example, to install programs into \$HOME/qpid-tools/bin, run this command:
$prog_name --prefix=\$HOME/qpid-tools