summaryrefslogtreecommitdiff
path: root/qpid/cpp/src/Makefile.am
diff options
context:
space:
mode:
authorMichael Goulish <mgoulish@apache.org>2010-05-24 18:25:46 +0000
committerMichael Goulish <mgoulish@apache.org>2010-05-24 18:25:46 +0000
commitba91599c45eeb8f3578cd34092302b2394b9ea69 (patch)
treeeca1f864eaa85a847ee10dab38554695f2aa5fc0 /qpid/cpp/src/Makefile.am
parenta496df01eec8f7c9989c6ec9fe89ea864a6b9cf9 (diff)
downloadqpid-python-ba91599c45eeb8f3578cd34092302b2394b9ea69.tar.gz
Jira QPID-2617 -- make sasl-based tests config files relocatable
Before this change, sasl-based testing cannot be fully automated because the sasl db must be located in the standard installation location of /etc/sasl2. * Created a new directory "sasl_config" under cpp/src/tests * added a new makefile fragment "sasl.mk" to cpp/src/Makefile.am conditionally included basedon HAVE_SASL, which is defined by configure. ( NOTE: should be in cpp/src/tests/Makefile.am, but getting an "saslpasswd2: generic failure" when I try that. ) * The sasl.mk fragment uses saslpasswd2 to create a sasl db in cpp/src/tests/sasl_config that defines two users with eponymous passwords. * In test cluster_authentication_soak.cpp, make the cluster name random. * make SaslAuthenticator code accept and use a config path * give cluster_authentication_soak self-test capability. the test is meant to detect two problems: - broker failure - perftest hang so give it flags that will force either of those conditions. This allows me to (anually) ensure that the test really does detect those conditions when they occur. git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@947748 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/src/Makefile.am')
-rw-r--r--qpid/cpp/src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/qpid/cpp/src/Makefile.am b/qpid/cpp/src/Makefile.am
index f2125eb22c..f3f8ac5f1c 100644
--- a/qpid/cpp/src/Makefile.am
+++ b/qpid/cpp/src/Makefile.am
@@ -268,6 +268,7 @@ if SSL
include ssl.mk
endif
+
# New 0-10 codec, to be integrated in future.
# libqpidamqp_0_10_la_SOURCES=
EXTRA_DIST +=\
@@ -488,6 +489,8 @@ if HAVE_SASL
libqpidcommon_la_SOURCES += qpid/sys/cyrus/CyrusSecurityLayer.h
libqpidcommon_la_SOURCES += qpid/sys/cyrus/CyrusSecurityLayer.cpp
libqpidcommon_la_LIBADD += -lsasl2
+
+include sasl.mk
endif
libqpidbroker_la_LIBADD = libqpidcommon.la -luuid