summaryrefslogtreecommitdiff
path: root/qpid/cpp/src/cluster.mk
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2008-09-05 19:53:44 +0000
committerAlan Conway <aconway@apache.org>2008-09-05 19:53:44 +0000
commit650dc8949488e88797a61908723619aca5fc8909 (patch)
treee09ce3d723a4255abe8355887677e855c225d2c0 /qpid/cpp/src/cluster.mk
parent79ffcd4b5cf08b435881dd28d1a673f287d42532 (diff)
downloadqpid-python-650dc8949488e88797a61908723619aca5fc8909.tar.gz
Fixed cluster membership notification.
Cluster events with RefCountedBuffers for queueing. PollableQueue clears bacth immediately. Improved perfdist: clients hit multiple brokers in a cluster. git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@692521 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/src/cluster.mk')
-rw-r--r--qpid/cpp/src/cluster.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/qpid/cpp/src/cluster.mk b/qpid/cpp/src/cluster.mk
index d5be6dfc57..cb07804550 100644
--- a/qpid/cpp/src/cluster.mk
+++ b/qpid/cpp/src/cluster.mk
@@ -25,7 +25,9 @@ libqpidcluster_la_SOURCES = \
qpid/cluster/WriteEstimate.cpp \
qpid/cluster/OutputInterceptor.h \
qpid/cluster/OutputInterceptor.cpp \
- qpid/cluster/ProxyInputHandler.h
+ qpid/cluster/ProxyInputHandler.h \
+ qpid/cluster/Event.h \
+ qpid/cluster/Event.cpp
libqpidcluster_la_LIBADD= -lcpg libqpidbroker.la