summaryrefslogtreecommitdiff
path: root/qpid/cpp/src/cluster.mk
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2009-11-24 20:07:24 +0000
committerAlan Conway <aconway@apache.org>2009-11-24 20:07:24 +0000
commita53255f11a8f8ee49aadec889981cea03934cc72 (patch)
tree680d2055af6297cfbf77e4eaa57f3c9f7d78f90d /qpid/cpp/src/cluster.mk
parent892cfdf7c3578d27603c4ae4a54ac5aec101d521 (diff)
downloadqpid-python-a53255f11a8f8ee49aadec889981cea03934cc72.tar.gz
Support for restarting a persistent cluster.
Option --cluster-size=N: members wait for N members before recovering store. Stores marked as clean/dirty. Automatically recover from clean store on restart. Stores marked with UUID to detect errors. Not yet implemented: consistency checks, manual recovery from all dirty stores. git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@883842 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/src/cluster.mk')
-rw-r--r--qpid/cpp/src/cluster.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/qpid/cpp/src/cluster.mk b/qpid/cpp/src/cluster.mk
index a2ec661ccf..9da6578df0 100644
--- a/qpid/cpp/src/cluster.mk
+++ b/qpid/cpp/src/cluster.mk
@@ -86,7 +86,9 @@ cluster_la_SOURCES = \
qpid/cluster/InitialStatusMap.cpp \
qpid/cluster/MemberSet.h \
qpid/cluster/MemberSet.cpp \
- qpid/cluster/types.h
+ qpid/cluster/types.h \
+ qpid/cluster/StoreStatus.h \
+ qpid/cluster/StoreStatus.cpp
cluster_la_LIBADD= -lcpg $(libcman) libqpidbroker.la libqpidclient.la
cluster_la_CXXFLAGS = $(AM_CXXFLAGS) -fno-strict-aliasing