summaryrefslogtreecommitdiff
path: root/qpid/cpp/src/qmf.mk
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2011-07-28 18:28:56 +0000
committerAlan Conway <aconway@apache.org>2011-07-28 18:28:56 +0000
commit95ad2adfc443b227eba224279188c36906c1db66 (patch)
tree14c91400e2284b2c4f782d203a60d44dbee31f9e /qpid/cpp/src/qmf.mk
parent8db25489a2971803b21d73814521b40731111bd5 (diff)
downloadqpid-python-95ad2adfc443b227eba224279188c36906c1db66.tar.gz
Merge branch 'visibility-hidden' into qpid-3163qpid-3163
git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/qpid-3163@1151956 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/src/qmf.mk')
-rw-r--r--qpid/cpp/src/qmf.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/qpid/cpp/src/qmf.mk b/qpid/cpp/src/qmf.mk
index f3462f1a93..aee51475f9 100644
--- a/qpid/cpp/src/qmf.mk
+++ b/qpid/cpp/src/qmf.mk
@@ -6,9 +6,9 @@
# to you under the Apache License, Version 2.0 (the
# "License"); you may not use this file except in compliance
# with the License. You may obtain a copy of the License at
-#
+#
# http://www.apache.org/licenses/LICENSE-2.0
-#
+#
# Unless required by applicable law or agreed to in writing,
# software distributed under the License is distributed on an
# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
@@ -19,7 +19,7 @@
#
# qmf library makefile fragment, to be included in Makefile.am
-#
+#
lib_LTLIBRARIES += \
libqmf.la \
libqmfengine.la \
@@ -155,6 +155,7 @@ libqmfengine_la_SOURCES = \
qmf/engine/ValueImpl.h
libqmf_la_LIBADD = libqmfengine.la
+libqmf_la_CXXFLAGS = $(AM_CXXFLAGS) -Dqmf_EXPORTS
libqmf2_la_LIBADD = libqpidmessaging.la libqpidtypes.la
libqmfengine_la_LIBADD = libqpidclient.la