summaryrefslogtreecommitdiff
path: root/qpid/cpp/src
diff options
context:
space:
mode:
authorGordon Sim <gsim@apache.org>2009-06-30 10:46:35 +0000
committerGordon Sim <gsim@apache.org>2009-06-30 10:46:35 +0000
commitede1268f15f52a8ac0c6b62ca497f5dc6afdf845 (patch)
treedceaff24e15389ef8490b4568863c71ea16a88e6 /qpid/cpp/src
parent09057487cfbba725abb775931e9c9ed689d03b01 (diff)
downloadqpid-python-ede1268f15f52a8ac0c6b62ca497f5dc6afdf845.tar.gz
Add some ring queue tests to make check-long (fix script to use QPID_PORT correctly)
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@789671 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/src')
-rw-r--r--qpid/cpp/src/tests/Makefile.am6
-rwxr-xr-xqpid/cpp/src/tests/ring_queue_test7
-rwxr-xr-xqpid/cpp/src/tests/run_ring_queue_test37
3 files changed, 44 insertions, 6 deletions
diff --git a/qpid/cpp/src/tests/Makefile.am b/qpid/cpp/src/tests/Makefile.am
index d922268ab4..f08d5a47ba 100644
--- a/qpid/cpp/src/tests/Makefile.am
+++ b/qpid/cpp/src/tests/Makefile.am
@@ -271,7 +271,9 @@ EXTRA_DIST += \
TestMessageStore.h \
TxMocks.h \
replication_test \
- run_perftest
+ run_perftest \
+ ring_queue_test \
+ run_ring_queue_test
check_LTLIBRARIES += libdlclose_noop.la
libdlclose_noop_la_LDFLAGS = -module -rpath $(abs_builddir)
@@ -282,7 +284,7 @@ CLEANFILES+=valgrind.out *.log *.vglog* dummy_test $(unit_wrappers)
# Longer running stability tests, not run by default check: target.
# Not run under valgrind, too slow
-LONG_TESTS+=start_broker fanout_perftest shared_perftest multiq_perftest topic_perftest run_failover_soak stop_broker \
+LONG_TESTS+=start_broker fanout_perftest shared_perftest multiq_perftest topic_perftest run_ring_queue_test run_failover_soak stop_broker \
reliable_replication_test federated_cluster_test_with_node_failure
EXTRA_DIST+=fanout_perftest shared_perftest multiq_perftest topic_perftest run_failover_soak reliable_replication_test \
diff --git a/qpid/cpp/src/tests/ring_queue_test b/qpid/cpp/src/tests/ring_queue_test
index b6479cf16d..5805989d7e 100755
--- a/qpid/cpp/src/tests/ring_queue_test
+++ b/qpid/cpp/src/tests/ring_queue_test
@@ -28,12 +28,13 @@ MESSAGES=10000
SENDERS=1
RECEIVERS=1
CONCURRENT=0
+BROKER_URL="-a ${QPID_BROKER:-localhost}:${QPID_PORT:-5672}"
setup() {
if [[ $DURABLE -gt 0 ]]; then
EXTRA_ARGS=" --durable"
fi
- qpid-config add queue $QUEUE_NAME --max-queue-count $LIMIT --limit-policy ring $EXTRA_ARGS
+ qpid-config $BROKER_URL add queue $QUEUE_NAME --max-queue-count $LIMIT --limit-policy ring $EXTRA_ARGS
}
send() {
@@ -47,7 +48,7 @@ receive() {
cleanup() {
rm -f sender_${QUEUE_NAME}_* receiver_${QUEUE_NAME}_*
- qpid-config add queue $QUEUE_NAME
+ qpid-config $BROKER_URL add queue $QUEUE_NAME
}
log() {
@@ -140,7 +141,6 @@ Options:
-q <queue> the name of the queue to use
-s <senders> the number of senders to start
-r <receivers> the number of receivers to start
- -u <url>
-l <limit> the limit for the ring queue
-m <messages> the number of messages to send
-c if specified, receivers will run concurrently with senders
@@ -156,7 +156,6 @@ while getopts "s:r:m:u:dch" opt ; do
s) SENDERS=$OPTARG ;;
r) RECEIVERS=$OPTARG ;;
m) MESSAGES=$OPTARG ;;
- u) URL=$OPTARG ;;
d) DURABLE=1 ;;
c) CONCURRENT=1 ;;
h) usage;;
diff --git a/qpid/cpp/src/tests/run_ring_queue_test b/qpid/cpp/src/tests/run_ring_queue_test
new file mode 100755
index 0000000000..fb90075458
--- /dev/null
+++ b/qpid/cpp/src/tests/run_ring_queue_test
@@ -0,0 +1,37 @@
+#!/bin/bash
+
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+#script to run a sequence of ring queue tests via make
+
+#setup path to find qpid-config and sender/receiver test progs
+srcdir=`dirname $0`
+PYTHON_DIR=$srcdir/../../../python
+export PYTHONPATH=$PYTHON_DIR
+export PATH=./:$PYTHON_DIR/commands:$PATH
+
+#set port to connect to via env var
+test -s qpidd.port && QPID_PORT=`cat qpidd.port`
+export QPID_PORT
+
+ring_queue_test -c -s 4 -r 4
+ring_queue_test -s 4 -r 0
+ring_queue_test -s 1 -r 1
+
+