summaryrefslogtreecommitdiff
path: root/qpid/cpp
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2007-01-05 19:09:10 +0000
committerAlan Conway <aconway@apache.org>2007-01-05 19:09:10 +0000
commitc3c56d78e62c8010dca46e78451ef6af12ed5eda (patch)
treeb2adb64b19b2d73b2ecc1102dd705495996c098f /qpid/cpp
parentec088fc2c0490ebe10e0d72894dcc2d278507874 (diff)
downloadqpid-python-c3c56d78e62c8010dca46e78451ef6af12ed5eda.tar.gz
2007-01-05 Jim Meyering <meyering@redhat.com>
* gen/Makefile.am (gen-src.mk) [CAN_GENERATE_CODE]: Emit an empty dependency for each generated file, in case they are renamed, removed, or no longer generated. Otherwise, "./bootstrap --build" would fail with e.g., `*** No rule to make target ../../gentools/templ.cpp/AMQP_HighestVersion.cpp.tmpl'. git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@493140 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp')
-rw-r--r--qpid/cpp/gen/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/qpid/cpp/gen/Makefile.am b/qpid/cpp/gen/Makefile.am
index e8edb35c6f..5d9473f615 100644
--- a/qpid/cpp/gen/Makefile.am
+++ b/qpid/cpp/gen/Makefile.am
@@ -11,7 +11,7 @@ MAINTAINERCLEANFILES = $(BUILT_SOURCES)
# Don't attempt to run the code generator unless configure has set
# CAN_GENERATE_CODE, indicating that the amqp.xml and tools needed
# to run the code generator are available.
-#
+#
if CAN_GENERATE_CODE
gentools_dir = $(srcdir)/../../gentools
@@ -40,6 +40,11 @@ gen-src.mk: timestamp
echo 'cxx_templates = '\\ \
&& find $(gentools_dir)/templ.cpp -name '*.tmpl' \
| sort -u | sed 's/.*/ & \\/;$$s/ \\//'; \
+ echo '# Empty rules, in case any of these files is removed,'; \
+ echo '# renamed, or no longer generated.'; \
+ echo '$$(spec):'; \
+ echo '$$(java_sources):'; \
+ echo '$$(cxx_templates):'; \
echo endif \
) >> $@-t
mv $@-t $@