summaryrefslogtreecommitdiff
path: root/qpid/cpp
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2006-12-08 18:36:33 +0000
committerAlan Conway <aconway@apache.org>2006-12-08 18:36:33 +0000
commite2e8ab7dbacb6d954ec123d47813a55aabee612b (patch)
tree4c954fceb9fc7f2a84b65b0cff2a8043f825965f /qpid/cpp
parent44ca5bf05d0292d2a8a214b295c1d45952d32111 (diff)
downloadqpid-python-e2e8ab7dbacb6d954ec123d47813a55aabee612b.tar.gz
2006-12-08 Based on a patch by Jim Meyering <meyering@redhat.com>
* tests/Makefile.am (run-python-tests): Depend on ../src/qpidd. Start a background job that will kill the daemon in 5 minutes. git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@484694 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp')
-rw-r--r--qpid/cpp/tests/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/qpid/cpp/tests/Makefile.am b/qpid/cpp/tests/Makefile.am
index e52a3512f0..1aab82c307 100644
--- a/qpid/cpp/tests/Makefile.am
+++ b/qpid/cpp/tests/Makefile.am
@@ -70,11 +70,10 @@ check: run-unit-tests run-python-tests
run-unit-tests: $(check_LTLIBRARIES)
DllPlugInTester -c -b .libs/*.so
-# TODO aconway 2006-12-01: Should also check for qpidd.
-run-python-tests: $(check_LTLIBRARIES)
- ../src/qpidd > qpidd.log 2>&1 &
+run-python-tests: $(check_LTLIBRARIES) ../src/qpidd
+ ../src/qpidd > qpidd.log 2>&1 & echo $$! > qpidd.pid
cd ../../python ; ./run-tests -v -I cpp_failing.txt
-
+ kill `cat qpidd.pid`
include gen.mk