summaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2014-06-26 00:03:01 +0000
committerAlan Conway <aconway@apache.org>2014-06-26 00:03:01 +0000
commitb40ba44073e03bc58421ec0dc7a7197ee0667470 (patch)
tree3968d2a77bbee27eb087a20f50ce4718b34ab27c /tools
parent120d457164d150f353cea1a479528d6a78c498aa (diff)
downloadqpid-python-b40ba44073e03bc58421ec0dc7a7197ee0667470.tar.gz
NO-JIRA: Fix tools/setup.py, was not respecting install prefix.
- Was installing into absolute /usr directories, changed to install relative to prefix. - Was installing to non-standard "/usr/shared" directory, changed to Unix standard "<prefix>/share" git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk/qpid@1605637 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'tools')
-rwxr-xr-xtools/setup.py18
1 files changed, 9 insertions, 9 deletions
diff --git a/tools/setup.py b/tools/setup.py
index 808a800222..52dc27aaaf 100755
--- a/tools/setup.py
+++ b/tools/setup.py
@@ -7,9 +7,9 @@
# to you under the Apache License, Version 2.0 (the
# "License"); you may not use this file except in compliance
# with the License. You may obtain a copy of the License at
-#
+#
# http://www.apache.org/licenses/LICENSE-2.0
-#
+#
# Unless required by applicable law or agreed to in writing,
# software distributed under the License is distributed on an
# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
@@ -47,13 +47,13 @@ setup(name="qpid-tools",
"src/py/qpid-stat",
"src/py/qpid-tool",
"src/py/qmf-tool"],
- data_files=[("/usr/libexec", ["src/py/qpid-qls-analyze"]),
- ("/usr/shared/qpid-tools/python/qlslibs",
- ["src/py/qlslibs/anal.py",
- "src/py/qlslibs/efp.py",
- "src/py/qlslibs/err.py",
- "src/py/qlslibs/jrnl.py",
- "src/py/qlslibs/utils.py"])],
+ data_files=[("libexec", ["src/py/qpid-qls-analyze"]),
+ ("share/qpid-tools/python/qlslibs",
+ ["src/py/qlslibs/anal.py",
+ "src/py/qlslibs/efp.py",
+ "src/py/qlslibs/err.py",
+ "src/py/qlslibs/jrnl.py",
+ "src/py/qlslibs/utils.py"])],
url="http://qpid.apache.org/",
license="Apache Software License",
description="Diagnostic and management tools for Apache Qpid brokers.",