summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--qpid/cpp/src/tests/cluster.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/qpid/cpp/src/tests/cluster.mk b/qpid/cpp/src/tests/cluster.mk
index c4216cbd3d..aa22d0e7c4 100644
--- a/qpid/cpp/src/tests/cluster.mk
+++ b/qpid/cpp/src/tests/cluster.mk
@@ -91,8 +91,11 @@ cluster_test_SOURCES = \
ForkedBroker.cpp \
PartialFailure.cpp \
ClusterFailover.cpp \
- InitialStatusMap.cpp \
- StoreStatus.cpp
+ InitialStatusMap.cpp
+
+# Moved this file here from cluster_test_SOURCES as it breaks the autotools build, but not the cmake
+# build and so we need to make sure it is present in the tarball
+EXTRA_DIST += StoreStatus.cpp
cluster_test_LDADD=$(lib_client) $(lib_broker) ../cluster.la -lboost_unit_test_framework