summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--qpid/cpp/src/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index c378c70fea..cace78902b 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -156,9 +156,11 @@ endif (VALGRIND_FOUND)
# Do not keep on linking against transitive library dependencies
# TODO Need to rework CMake files to use INTERFACE_LINK_LIBRARIES target property
-# When that is done we can remove the next 2 lines completely
+# When that is done we can remove the next 4 lines completely
set (CMAKE_LINK_INTERFACE_LIBRARIES "")
-cmake_policy(SET CMP0022 OLD)
+if (DEFINED CMAKE_VERSION AND CMAKE_VERSION VERSION_GREATER "2.8.11")
+ cmake_policy(SET CMP0022 OLD)
+endif (DEFINED CMAKE_VERSION AND CMAKE_VERSION VERSION_GREATER "2.8.11")
if (CMAKE_COMPILER_IS_GNUCXX)
# Warnings: Enable as many as possible, keep the code clean. Please