summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xqpid/tools/setup.py20
1 files changed, 19 insertions, 1 deletions
diff --git a/qpid/tools/setup.py b/qpid/tools/setup.py
index 068af322d0..cac8c4decd 100755
--- a/qpid/tools/setup.py
+++ b/qpid/tools/setup.py
@@ -19,6 +19,20 @@
#
from distutils.core import setup
+pypi_long_description = """
+
+===========
+qpidtoollibs
+===========
+
+qpidtoollibs provides a useful BrokerAgent object for managing a Qpid broker
+using Qpid Management Framework (QMF).
+
+This library depends on the qpid.messaging python client to send AMQP messaging
+containing QMF commands to the Qpid broker.
+
+"""
+
setup(name="qpid-tools",
version="0.27",
author="Apache Qpid",
@@ -35,4 +49,8 @@ setup(name="qpid-tools",
"src/py/qmf-tool"],
url="http://qpid.apache.org/",
license="Apache Software License",
- description="Diagnostic and management tools for Apache Qpid brokers.")
+ description="Diagnostic and management tools for Apache Qpid brokers.",
+ long_description=pypi_long_description,
+ install_requires=[
+ "qpid-python >= 0.26",
+ ])