summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cpp/lib/client/ClientExchange.h2
-rw-r--r--cpp/lib/client/Connection.h2
-rw-r--r--cpp/tests/Makefile.am6
3 files changed, 2 insertions, 8 deletions
diff --git a/cpp/lib/client/ClientExchange.h b/cpp/lib/client/ClientExchange.h
index 296a1920a6..a8ac21fa9b 100644
--- a/cpp/lib/client/ClientExchange.h
+++ b/cpp/lib/client/ClientExchange.h
@@ -39,7 +39,7 @@ namespace client {
* of the binding and the type of exchange.
*
* There are some standard exchange instances that are predeclared
- * on all AMQP brokers. These are defined as statisc members
+ * on all AMQP brokers. These are defined as static members
* STANDARD_DIRECT_EXCHANGE, STANDARD_TOPIC_EXCHANGE and
* STANDARD_HEADERS_EXCHANGE. There is also the 'default' exchange
* (member DEFAULT_EXCHANGE) which is nameless and of type
diff --git a/cpp/lib/client/Connection.h b/cpp/lib/client/Connection.h
index c008463ff6..4fa95a1439 100644
--- a/cpp/lib/client/Connection.h
+++ b/cpp/lib/client/Connection.h
@@ -145,7 +145,7 @@ class Connection : public ConnectionForChannel
void open(const std::string& host, int port = 5672,
const std::string& uid = "guest",
const std::string& pwd = "guest",
- const std::string& virtualhost = "");
+ const std::string& virtualhost = "/");
/**
* Close the connection with optional error information for the peer.
diff --git a/cpp/tests/Makefile.am b/cpp/tests/Makefile.am
index 59bb1b82e9..edad0945f3 100644
--- a/cpp/tests/Makefile.am
+++ b/cpp/tests/Makefile.am
@@ -10,12 +10,6 @@ INCLUDES = \
$(APR_CXXFLAGS)
# Unit tests
-client_tests = \
- client_test \
- echo_service \
- topic_listener \
- topic_publisher
-
broker_tests = \
AccumulatedAckTest \
BrokerChannelTest \