summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cpp/README-dev8
-rw-r--r--cpp/gen/Makefile.am2
-rw-r--r--cpp/lib/broker/Makefile.am3
-rw-r--r--cpp/lib/client/Makefile.am5
4 files changed, 11 insertions, 7 deletions
diff --git a/cpp/README-dev b/cpp/README-dev
index 60c43d0ef5..37f66604f1 100644
--- a/cpp/README-dev
+++ b/cpp/README-dev
@@ -6,10 +6,12 @@ sudo cp /usr/share/aclocal/pkg.m4 `aclocal --print-ac-dir`
== Prerequisites ==
If you have taken the sources from SVN you will need the following
-packages (or later) to build Qpid. We prefer to avoid spending time
-accommodating older versions of these packages, so please make sure
-that you have the latest stable version.
+packages (or later)
+We prefer to avoid spending time accommodating older versions of these
+packages, so please make sure that you have the latest stable version.
+
+ * All the prerequisites listed in README-dist.
* GNU make <http://www.gnu.org/software/make/>
* autoconf <http://www.gnu.org/software/autoconf/>
* automake <http://www.gnu.org/software/automake/>
diff --git a/cpp/gen/Makefile.am b/cpp/gen/Makefile.am
index 796707b411..c9af573f3a 100644
--- a/cpp/gen/Makefile.am
+++ b/cpp/gen/Makefile.am
@@ -11,7 +11,7 @@ DISTCLEANFILES = $(BUILT_SOURCES) timestamp gen-src.mk
# Don't attempt to run the code generator unless configure has set
# CAN_GENERATE_CODE, indicating that the amqp.xml and tools needed
# to run the code generator are available.
-#
+#
if CAN_GENERATE_CODE
gentools_dir = $(srcdir)/../../gentools
diff --git a/cpp/lib/broker/Makefile.am b/cpp/lib/broker/Makefile.am
index 760c6d61e2..68649c2b28 100644
--- a/cpp/lib/broker/Makefile.am
+++ b/cpp/lib/broker/Makefile.am
@@ -7,8 +7,9 @@ INCLUDES = \
$(APR_CXXFLAGS)
lib_LTLIBRARIES = libqpidbroker.la
+libqpidbroker_la_LIBADD = ../common/libqpidcommon.la
libqpidbroker_la_LDFLAGS = -version-info $(LIBTOOL_VERSION_INFO_ARG)
-libqpidbroker_la_SOURCES = \
+libqpidbroker_la_SOURCES = \
AccumulatedAck.cpp \
AccumulatedAck.h \
AutoDelete.cpp \
diff --git a/cpp/lib/client/Makefile.am b/cpp/lib/client/Makefile.am
index 9f345d866d..1e10a2a244 100644
--- a/cpp/lib/client/Makefile.am
+++ b/cpp/lib/client/Makefile.am
@@ -7,8 +7,9 @@ INCLUDES = \
$(APR_CXXFLAGS)
lib_LTLIBRARIES = libqpidclient.la
+libqpidclient_la_LIBADD = ../common/libqpidcommon.la
libqpidclient_la_LDFLAGS = -version-info $(LIBTOOL_VERSION_INFO_ARG)
-libqpidclient_la_SOURCES = \
+libqpidclient_la_SOURCES = \
ClientChannel.cpp \
ClientExchange.cpp \
ClientMessage.cpp \
@@ -20,7 +21,7 @@ libqpidclient_la_SOURCES = \
MessageListener.cpp \
ResponseHandler.cpp \
ReturnedMessageHandler.cpp
-pkginclude_HEADERS = \
+pkginclude_HEADERS = \
ClientChannel.h \
ClientExchange.h \
ClientMessage.h \