summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xqpid/cpp/bindings/qmf/tests/run_interop_tests4
-rwxr-xr-xqpid/cpp/src/tests/run_cli_tests2
-rw-r--r--qpid/cpp/src/tests/test_env.sh.in6
-rwxr-xr-xqpid/extras/qmf/setup.py28
-rw-r--r--qpid/extras/qmf/src/py/qmf/__init__.py (renamed from qpid/python/qmf/__init__.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf/console.py (renamed from qpid/python/qmf/console.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/__init__.py (renamed from qpid/python/qmf2/__init__.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/agent.py (renamed from qpid/python/qmf2/agent.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/common.py (renamed from qpid/python/qmf2/common.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/console.py (renamed from qpid/python/qmf2/console.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/tests/__init__.py (renamed from qpid/python/qmf2/tests/__init__.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/tests/agent_discovery.py (renamed from qpid/python/qmf2/tests/agent_discovery.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/tests/agent_test.py (renamed from qpid/python/qmf2/tests/agent_test.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/tests/async_method.py (renamed from qpid/python/qmf2/tests/async_method.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/tests/async_query.py (renamed from qpid/python/qmf2/tests/async_query.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/tests/basic_method.py (renamed from qpid/python/qmf2/tests/basic_method.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/tests/basic_query.py (renamed from qpid/python/qmf2/tests/basic_query.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/tests/console_test.py (renamed from qpid/python/qmf2/tests/console_test.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/tests/events.py (renamed from qpid/python/qmf2/tests/events.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/tests/multi_response.py (renamed from qpid/python/qmf2/tests/multi_response.py)0
-rw-r--r--qpid/extras/qmf/src/py/qmf2/tests/obj_gets.py (renamed from qpid/python/qmf2/tests/obj_gets.py)0
-rw-r--r--qpid/python/Makefile8
-rw-r--r--qpid/python/setup.py11
-rwxr-xr-xqpid/tools/setup.py33
-rwxr-xr-xqpid/tools/src/py/qpid-cluster (renamed from qpid/python/commands/qpid-cluster)0
-rwxr-xr-xqpid/tools/src/py/qpid-config (renamed from qpid/python/commands/qpid-config)0
-rwxr-xr-xqpid/tools/src/py/qpid-printevents (renamed from qpid/python/commands/qpid-printevents)0
-rwxr-xr-xqpid/tools/src/py/qpid-queue-stats (renamed from qpid/python/commands/qpid-queue-stats)0
-rwxr-xr-xqpid/tools/src/py/qpid-route (renamed from qpid/python/commands/qpid-route)0
-rwxr-xr-xqpid/tools/src/py/qpid-stat (renamed from qpid/python/commands/qpid-stat)0
-rwxr-xr-xqpid/tools/src/py/qpid-tool (renamed from qpid/python/commands/qpid-tool)0
31 files changed, 73 insertions, 19 deletions
diff --git a/qpid/cpp/bindings/qmf/tests/run_interop_tests b/qpid/cpp/bindings/qmf/tests/run_interop_tests
index 1669fe0189..83e7f2593b 100755
--- a/qpid/cpp/bindings/qmf/tests/run_interop_tests
+++ b/qpid/cpp/bindings/qmf/tests/run_interop_tests
@@ -24,6 +24,8 @@ MY_DIR=`dirname \`which $0\``
QPID_DIR=${MY_DIR}/../../../..
BUILD_DIR=../../..
PYTHON_DIR=${QPID_DIR}/python
+QMF_DIR=${QPID_DIR}/extras/qmf
+QMF_DIR_PY=${QMF_DIR}/src/py
BROKER_DIR=${BUILD_DIR}/src
API_DIR=${BUILD_DIR}/bindings/qmf
SPEC_DIR=${QPID_DIR}/specs
@@ -66,7 +68,7 @@ TESTS_FAILED=0
if test -d ${PYTHON_DIR} ; then
start_broker
echo "Running qmf interop tests using broker on port $BROKER_PORT"
- PYTHONPATH=${PYTHON_DIR}:${MY_DIR}
+ PYTHONPATH=${PYTHON_DIR}:${QMF_DIR_PY}:${MY_DIR}
export PYTHONPATH
if test -d ${PYTHON_LIB_DIR} ; then
diff --git a/qpid/cpp/src/tests/run_cli_tests b/qpid/cpp/src/tests/run_cli_tests
index f3cdea0d4f..3f1388b9f5 100755
--- a/qpid/cpp/src/tests/run_cli_tests
+++ b/qpid/cpp/src/tests/run_cli_tests
@@ -70,7 +70,7 @@ stop_brokers() {
if test -d ${PYTHON_DIR} ; then
start_brokers
echo "Running CLI tests using brokers on ports $LOCAL_PORT $REMOTE_PORT"
- $PYTHON_COMMANDS/qpid-python-test -m cli_tests -b localhost:$LOCAL_PORT -Dremote-port=$REMOTE_PORT -Dcli-dir=$CLI_DIR $targs $@
+ $QPID_PYTHON_TEST -m cli_tests -b localhost:$LOCAL_PORT -Dremote-port=$REMOTE_PORT -Dcli-dir=$CLI_DIR $targs $@
RETCODE=$?
stop_brokers
if test x$RETCODE != x0; then
diff --git a/qpid/cpp/src/tests/test_env.sh.in b/qpid/cpp/src/tests/test_env.sh.in
index 0ce7fabe8c..87fbbd128b 100644
--- a/qpid/cpp/src/tests/test_env.sh.in
+++ b/qpid/cpp/src/tests/test_env.sh.in
@@ -36,8 +36,10 @@ if [ ! -d $PYTHON_DIR -a -d $top_srcdir/../python ]; then
fi
export QPID_TESTS=$top_srcdir/../tests
export QPID_TESTS_PY=$QPID_TESTS/src/py
-export PYTHON_COMMANDS=$PYTHON_DIR/commands
-export PYTHONPATH=$srcdir:$PYTHON_DIR:$PYTHON_COMMANDS:$QPID_TESTS_PY:$PYTHONPATH
+export QPID_TOOLS=$top_srcdir/../tools
+export QMF_LIB=$top_srcdir/../extras/qmf/src/py
+export PYTHON_COMMANDS=$QPID_TOOLS/src/py
+export PYTHONPATH=$srcdir:$PYTHON_DIR:$PYTHON_COMMANDS:$QPID_TESTS_PY:$QMF_LIB:$PYTHONPATH
export QPID_CONFIG_EXEC=$PYTHON_COMMANDS/qpid-config
export QPID_ROUTE_EXEC=$PYTHON_COMMANDS/qpid-route
export QPID_CLUSTER_EXEC=$PYTHON_COMMANDS/qpid-cluster
diff --git a/qpid/extras/qmf/setup.py b/qpid/extras/qmf/setup.py
new file mode 100755
index 0000000000..b7e47ce135
--- /dev/null
+++ b/qpid/extras/qmf/setup.py
@@ -0,0 +1,28 @@
+#!/usr/bin/env python
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+from distutils.core import setup
+
+setup(name="qpid-qmf",
+ version="0.7",
+ packages=["qmf", "qmf2", "qmf2.tests"],
+ package_dir={"": "src/py"},
+ url="http://qpid.apache.org/",
+ license="Apache Software License",
+ description="QMF Library")
diff --git a/qpid/python/qmf/__init__.py b/qpid/extras/qmf/src/py/qmf/__init__.py
index 31d5a2ef58..31d5a2ef58 100644
--- a/qpid/python/qmf/__init__.py
+++ b/qpid/extras/qmf/src/py/qmf/__init__.py
diff --git a/qpid/python/qmf/console.py b/qpid/extras/qmf/src/py/qmf/console.py
index 45004716a8..45004716a8 100644
--- a/qpid/python/qmf/console.py
+++ b/qpid/extras/qmf/src/py/qmf/console.py
diff --git a/qpid/python/qmf2/__init__.py b/qpid/extras/qmf/src/py/qmf2/__init__.py
index 31d5a2ef58..31d5a2ef58 100644
--- a/qpid/python/qmf2/__init__.py
+++ b/qpid/extras/qmf/src/py/qmf2/__init__.py
diff --git a/qpid/python/qmf2/agent.py b/qpid/extras/qmf/src/py/qmf2/agent.py
index a6b3c39ad1..a6b3c39ad1 100644
--- a/qpid/python/qmf2/agent.py
+++ b/qpid/extras/qmf/src/py/qmf2/agent.py
diff --git a/qpid/python/qmf2/common.py b/qpid/extras/qmf/src/py/qmf2/common.py
index 8107b86666..8107b86666 100644
--- a/qpid/python/qmf2/common.py
+++ b/qpid/extras/qmf/src/py/qmf2/common.py
diff --git a/qpid/python/qmf2/console.py b/qpid/extras/qmf/src/py/qmf2/console.py
index c13cf70755..c13cf70755 100644
--- a/qpid/python/qmf2/console.py
+++ b/qpid/extras/qmf/src/py/qmf2/console.py
diff --git a/qpid/python/qmf2/tests/__init__.py b/qpid/extras/qmf/src/py/qmf2/tests/__init__.py
index 186f09349e..186f09349e 100644
--- a/qpid/python/qmf2/tests/__init__.py
+++ b/qpid/extras/qmf/src/py/qmf2/tests/__init__.py
diff --git a/qpid/python/qmf2/tests/agent_discovery.py b/qpid/extras/qmf/src/py/qmf2/tests/agent_discovery.py
index 59b65221e0..59b65221e0 100644
--- a/qpid/python/qmf2/tests/agent_discovery.py
+++ b/qpid/extras/qmf/src/py/qmf2/tests/agent_discovery.py
diff --git a/qpid/python/qmf2/tests/agent_test.py b/qpid/extras/qmf/src/py/qmf2/tests/agent_test.py
index 14d8ada197..14d8ada197 100644
--- a/qpid/python/qmf2/tests/agent_test.py
+++ b/qpid/extras/qmf/src/py/qmf2/tests/agent_test.py
diff --git a/qpid/python/qmf2/tests/async_method.py b/qpid/extras/qmf/src/py/qmf2/tests/async_method.py
index 556b62756f..556b62756f 100644
--- a/qpid/python/qmf2/tests/async_method.py
+++ b/qpid/extras/qmf/src/py/qmf2/tests/async_method.py
diff --git a/qpid/python/qmf2/tests/async_query.py b/qpid/extras/qmf/src/py/qmf2/tests/async_query.py
index 3a9a767bf0..3a9a767bf0 100644
--- a/qpid/python/qmf2/tests/async_query.py
+++ b/qpid/extras/qmf/src/py/qmf2/tests/async_query.py
diff --git a/qpid/python/qmf2/tests/basic_method.py b/qpid/extras/qmf/src/py/qmf2/tests/basic_method.py
index be2bdff9ab..be2bdff9ab 100644
--- a/qpid/python/qmf2/tests/basic_method.py
+++ b/qpid/extras/qmf/src/py/qmf2/tests/basic_method.py
diff --git a/qpid/python/qmf2/tests/basic_query.py b/qpid/extras/qmf/src/py/qmf2/tests/basic_query.py
index dd321cb4bb..dd321cb4bb 100644
--- a/qpid/python/qmf2/tests/basic_query.py
+++ b/qpid/extras/qmf/src/py/qmf2/tests/basic_query.py
diff --git a/qpid/python/qmf2/tests/console_test.py b/qpid/extras/qmf/src/py/qmf2/tests/console_test.py
index ac0e064f20..ac0e064f20 100644
--- a/qpid/python/qmf2/tests/console_test.py
+++ b/qpid/extras/qmf/src/py/qmf2/tests/console_test.py
diff --git a/qpid/python/qmf2/tests/events.py b/qpid/extras/qmf/src/py/qmf2/tests/events.py
index e55dc8572e..e55dc8572e 100644
--- a/qpid/python/qmf2/tests/events.py
+++ b/qpid/extras/qmf/src/py/qmf2/tests/events.py
diff --git a/qpid/python/qmf2/tests/multi_response.py b/qpid/extras/qmf/src/py/qmf2/tests/multi_response.py
index d3d00a70c5..d3d00a70c5 100644
--- a/qpid/python/qmf2/tests/multi_response.py
+++ b/qpid/extras/qmf/src/py/qmf2/tests/multi_response.py
diff --git a/qpid/python/qmf2/tests/obj_gets.py b/qpid/extras/qmf/src/py/qmf2/tests/obj_gets.py
index 5b1446bb3a..5b1446bb3a 100644
--- a/qpid/python/qmf2/tests/obj_gets.py
+++ b/qpid/extras/qmf/src/py/qmf2/tests/obj_gets.py
diff --git a/qpid/python/Makefile b/qpid/python/Makefile
index 59d38bd53f..ebae6a8ea4 100644
--- a/qpid/python/Makefile
+++ b/qpid/python/Makefile
@@ -31,7 +31,7 @@ else
AMQP_SPEC_DIR=$(PWD)/$(DATA_DIR)/amqp
endif
-DIRS=qmf qpid mllib examples
+DIRS=qpid mllib examples
SRCS=$(shell find $(DIRS) -name "*.py") qpid_config.py
BUILD=build
TARGETS=$(SRCS:%.py=$(BUILD)/%.py)
@@ -71,12 +71,8 @@ install: build
install -pm 0644 $(BUILD)/qpid/tests/*.* $(PYTHON_LIB)/qpid/tests
$(PYCC) $(PYTHON_LIB)/qpid
- install -d $(PYTHON_LIB)/qmf
- install -pm 0644 LICENSE.txt NOTICE.txt qmf/*.* $(PYTHON_LIB)/qmf
- $(PYCC) $(PYTHON_LIB)/qmf
-
install -d $(EXEC_PREFIX)
- install -pm 0755 qpid-python-test commands/* $(EXEC_PREFIX)
+ install -pm 0755 qpid-python-test $(EXEC_PREFIX)
clean:
rm -rf $(BUILD)
diff --git a/qpid/python/setup.py b/qpid/python/setup.py
index 5178bad0ed..2bd6e7fe0d 100644
--- a/qpid/python/setup.py
+++ b/qpid/python/setup.py
@@ -21,15 +21,8 @@ from distutils.core import setup
setup(name="qpid",
version="0.7",
- packages=["mllib", "qpid", "qpid.tests", "qmf", "qmf2", "qmf2.tests"],
- scripts=["qpid-python-test",
- "commands/qpid-cluster",
- "commands/qpid-config",
- "commands/qpid-printevents",
- "commands/qpid-queue-stats",
- "commands/qpid-route",
- "commands/qpid-stat",
- "commands/qpid-tool"],
+ packages=["mllib", "qpid", "qpid.tests"],
+ scripts=["qpid-python-test"],
url="http://qpid.apache.org/",
license="Apache Software License",
description="Python language client implementation for Apache Qpid")
diff --git a/qpid/tools/setup.py b/qpid/tools/setup.py
new file mode 100755
index 0000000000..eeabd858ae
--- /dev/null
+++ b/qpid/tools/setup.py
@@ -0,0 +1,33 @@
+#!/usr/bin/env python
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+from distutils.core import setup
+
+setup(name="qpid-tools",
+ version="0.7",
+ scripts=["src/py/qpid-cluster",
+ "src/py/qpid-config",
+ "src/py/qpid-printevents",
+ "src/py/qpid-queue-stats",
+ "src/py/qpid-route",
+ "src/py/qpid-stat",
+ "src/py/qpid-tool"],
+ url="http://qpid.apache.org/",
+ license="Apache Software License",
+ description="Diagnostic and management tools for Apache Qpid brokers.")
diff --git a/qpid/python/commands/qpid-cluster b/qpid/tools/src/py/qpid-cluster
index 6d64765184..6d64765184 100755
--- a/qpid/python/commands/qpid-cluster
+++ b/qpid/tools/src/py/qpid-cluster
diff --git a/qpid/python/commands/qpid-config b/qpid/tools/src/py/qpid-config
index 0db42bc6c7..0db42bc6c7 100755
--- a/qpid/python/commands/qpid-config
+++ b/qpid/tools/src/py/qpid-config
diff --git a/qpid/python/commands/qpid-printevents b/qpid/tools/src/py/qpid-printevents
index 0c1b618a1f..0c1b618a1f 100755
--- a/qpid/python/commands/qpid-printevents
+++ b/qpid/tools/src/py/qpid-printevents
diff --git a/qpid/python/commands/qpid-queue-stats b/qpid/tools/src/py/qpid-queue-stats
index 3b8a0dcb19..3b8a0dcb19 100755
--- a/qpid/python/commands/qpid-queue-stats
+++ b/qpid/tools/src/py/qpid-queue-stats
diff --git a/qpid/python/commands/qpid-route b/qpid/tools/src/py/qpid-route
index 9965047000..9965047000 100755
--- a/qpid/python/commands/qpid-route
+++ b/qpid/tools/src/py/qpid-route
diff --git a/qpid/python/commands/qpid-stat b/qpid/tools/src/py/qpid-stat
index c6fc5ef0da..c6fc5ef0da 100755
--- a/qpid/python/commands/qpid-stat
+++ b/qpid/tools/src/py/qpid-stat
diff --git a/qpid/python/commands/qpid-tool b/qpid/tools/src/py/qpid-tool
index 05afcc9732..05afcc9732 100755
--- a/qpid/python/commands/qpid-tool
+++ b/qpid/tools/src/py/qpid-tool