summaryrefslogtreecommitdiff
path: root/cpp/docs/api/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/docs/api/Makefile.am')
-rw-r--r--cpp/docs/api/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/cpp/docs/api/Makefile.am b/cpp/docs/api/Makefile.am
index ed7a00b20c..a02e7dd084 100644
--- a/cpp/docs/api/Makefile.am
+++ b/cpp/docs/api/Makefile.am
@@ -1,22 +1,21 @@
-
html: doxygen.tstamp
dist-hook: html
-EXTRA_DIST=html
+EXTRA_DIST = \
+ html \
+ user.doxygen
SOURCES = \
$(wildcard $(top_srcdir)/gen/*.h) \
$(wildcard $(top_srcdir)/lib/common/*.h) \
$(wildcard $(top_srcdir)/lib/common/sys/*.h) \
$(wildcard $(top_srcdir)/lib/common/framing/*.h) \
- $(wildcard $(top_srcdir)/lib/client/*.h)
+ $(wildcard $(top_srcdir)/lib/client/*.h)
doxygen.tstamp: user.doxygen $(SOURCES)
- doxygen user.doxygen
+ doxygen $(srcdir)/user.doxygen
touch $@
clean-local:
rm -rf docs.tstamp html man latex doxygen.tstamp xml
-
-