summaryrefslogtreecommitdiff
path: root/cpp/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/examples/Makefile.am')
-rw-r--r--cpp/examples/Makefile.am38
1 files changed, 29 insertions, 9 deletions
diff --git a/cpp/examples/Makefile.am b/cpp/examples/Makefile.am
index 5415cae1a9..c6cc308d98 100644
--- a/cpp/examples/Makefile.am
+++ b/cpp/examples/Makefile.am
@@ -1,29 +1,49 @@
-SUBDIRS = direct fanout pub-sub request-response
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+SUBDIRS = direct fanout pub-sub request-response failover qmf-console tradedemo messaging
if HAVE_XML
SUBDIRS += xml-exchange
+ broker_args = "--no-module-dir --data-dir \"\" --auth no --load-module $(top_builddir)/src/.libs/xml.so"
endif
if !HAVE_XML
exclude_examples_regexp="xml" # Exclude XML examples.
+ broker_args = "--no-module-dir --data-dir \"\" --auth no"
endif
MAKEDIST=.libs/Makefile
-SUBMAKE=' for d in $(SUBDIRS) ; do $$(MAKE) -C $$$$d $$@ ; done'
+
$(MAKEDIST): Makefile
mkdir -p .libs
- @$(ECHO) all: > $(MAKEDIST)
- @$(ECHO) $(SUBMAKE) >> $(MAKEDIST)
- @$(ECHO) clean: >> $(MAKEDIST)
- @$(ECHO) $(SUBMAKE) >> $(MAKEDIST)
+ @(echo 'all clean:' ; \
+ echo ' for d in $(SUBDIRS) ; do $$(MAKE) -C $$$$d $$@ ; done' ; \
+ ) > $(MAKEDIST)
examplesdir=$(pkgdatadir)/examples
-examples_DATA = README $(MAKEDIST)
+dist_examples_DATA = README.txt $(MAKEDIST)
-EXTRA_DIST = $(examples_DATA) README.verify verify verify_all
+EXTRA_DIST = README.verify verify verify_all examples.sln CMakeLists.txt
# For older versions of automake
abs_top_srcdir = @abs_top_srcdir@
+abs_top_builddir = @abs_top_builddir@
# Verify the examples in the buid tree.
check-local:
- $(srcdir)/verify_all $(abs_top_srcdir)/.. $(top_builddir)/src/qpidd $(exclude_examples_regexp)
+ $(srcdir)/verify_all $(abs_top_srcdir)/.. $(abs_top_builddir) $(broker_args) $(exclude_examples_regexp)