summaryrefslogtreecommitdiff
path: root/cpp/examples/pub-sub/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/examples/pub-sub/Makefile.am')
-rw-r--r--cpp/examples/pub-sub/Makefile.am29
1 files changed, 23 insertions, 6 deletions
diff --git a/cpp/examples/pub-sub/Makefile.am b/cpp/examples/pub-sub/Makefile.am
index 8446a1c40c..8673174a06 100644
--- a/cpp/examples/pub-sub/Makefile.am
+++ b/cpp/examples/pub-sub/Makefile.am
@@ -1,5 +1,24 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
examplesdir=$(pkgdatadir)/examples/pub-sub
+MAKELDFLAGS=$(CLIENTFLAGS)
include $(top_srcdir)/examples/makedist.mk
noinst_PROGRAMS=topic_listener topic_publisher
@@ -17,14 +36,12 @@ examples_DATA= \
EXTRA_DIST= \
$(examples_DATA) \
+ CMakeLists.txt \
verify \
verify.in \
verify_cpp_python \
verify_cpp_python.in \
verify_python_cpp \
- verify_python_cpp.in
-
-
-
-
-
+ verify_python_cpp.in \
+ pub-sub_topic_listener.vcproj \
+ pub-sub_topic_publisher.vcproj