summaryrefslogtreecommitdiff
path: root/cpp/examples/xml-exchange/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/examples/xml-exchange/Makefile.am')
-rw-r--r--cpp/examples/xml-exchange/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/cpp/examples/xml-exchange/Makefile.am b/cpp/examples/xml-exchange/Makefile.am
index 1b25a8750d..e91cec370d 100644
--- a/cpp/examples/xml-exchange/Makefile.am
+++ b/cpp/examples/xml-exchange/Makefile.am
@@ -1,5 +1,24 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
examplesdir=$(pkgdatadir)/examples/xml-exchange
+MAKELDFLAGS=$(CLIENTFLAGS)
include $(top_srcdir)/examples/makedist.mk
noinst_PROGRAMS=declare_queues xml_producer listener
@@ -14,7 +33,8 @@ listener_SOURCES=listener.cpp
listener_LDADD=$(CLIENT_LIB)
EXTRA_DIST= \
- README
+ README \
+ CMakeLists.txt
examples_DATA= \
$(EXTRA_DIST) \