summaryrefslogtreecommitdiff
path: root/cpp/lib/broker/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/lib/broker/Makefile.am')
-rw-r--r--cpp/lib/broker/Makefile.am81
1 files changed, 81 insertions, 0 deletions
diff --git a/cpp/lib/broker/Makefile.am b/cpp/lib/broker/Makefile.am
new file mode 100644
index 0000000000..f02dc4f545
--- /dev/null
+++ b/cpp/lib/broker/Makefile.am
@@ -0,0 +1,81 @@
+AM_CXXFLAGS = $(WARNING_CFLAGS)
+INCLUDES = \
+ -I$(top_srcdir)/gen \
+ -I$(top_srcdir)/lib/common \
+ -I$(top_srcdir)/lib/common/sys \
+ -I$(top_srcdir)/lib/common/framing \
+ $(APR_CXXFLAGS)
+
+lib_LTLIBRARIES = libbroker.la
+libbroker_la_LDFLAGS = -version-info $(LIBTOOL_VERSION_INFO_ARG)
+libbroker_la_SOURCES = \
+ AccumulatedAck.cpp \
+ AccumulatedAck.h \
+ AutoDelete.cpp \
+ AutoDelete.h \
+ Binding.h \
+ Broker.cpp \
+ Broker.h \
+ BrokerChannel.cpp \
+ BrokerChannel.h \
+ BrokerExchange.h \
+ BrokerMessage.cpp \
+ BrokerMessage.h \
+ BrokerQueue.cpp \
+ BrokerQueue.h \
+ Configuration.cpp \
+ Configuration.h \
+ ConnectionToken.h \
+ Consumer.h \
+ Content.h \
+ DeletingTxOp.cpp \
+ DeletingTxOp.h \
+ Deliverable.h \
+ DeliverableMessage.cpp \
+ DeliverableMessage.h \
+ DeliveryRecord.cpp \
+ DeliveryRecord.h \
+ DirectExchange.cpp \
+ DirectExchange.h \
+ ExchangeBinding.cpp \
+ ExchangeBinding.h \
+ ExchangeRegistry.cpp \
+ ExchangeRegistry.h \
+ FanOutExchange.cpp \
+ FanOutExchange.h \
+ HeadersExchange.cpp \
+ HeadersExchange.h \
+ InMemoryContent.cpp \
+ InMemoryContent.h \
+ LazyLoadedContent.cpp \
+ LazyLoadedContent.h \
+ MessageBuilder.cpp \
+ MessageBuilder.h \
+ MessageStore.h \
+ MessageStoreModule.cpp \
+ MessageStoreModule.h \
+ NameGenerator.cpp \
+ NameGenerator.h \
+ NullMessageStore.cpp \
+ NullMessageStore.h \
+ Prefetch.h \
+ QueuePolicy.cpp \
+ QueuePolicy.h \
+ QueueRegistry.cpp \
+ QueueRegistry.h \
+ RecoveryManager.cpp \
+ RecoveryManager.h \
+ SessionHandlerFactoryImpl.cpp \
+ SessionHandlerFactoryImpl.h \
+ SessionHandlerImpl.cpp \
+ SessionHandlerImpl.h \
+ TopicExchange.cpp \
+ TopicExchange.h \
+ TransactionalStore.h \
+ TxAck.cpp \
+ TxAck.h \
+ TxBuffer.cpp \
+ TxBuffer.h \
+ TxOp.h \
+ TxPublish.cpp \
+ TxPublish.h