summaryrefslogtreecommitdiff
path: root/cpp/rpm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/rpm/Makefile.am')
-rw-r--r--cpp/rpm/Makefile.am15
1 files changed, 5 insertions, 10 deletions
diff --git a/cpp/rpm/Makefile.am b/cpp/rpm/Makefile.am
index 887b3112c6..3149e26591 100644
--- a/cpp/rpm/Makefile.am
+++ b/cpp/rpm/Makefile.am
@@ -10,22 +10,17 @@ RPMOPTS=--define "_sourcedir ${abs_top_srcdir}" --define "_topdir ${abs_builddir
clean:
rm -rf BUILD RPMS SOURCES SPECS SRPMS
-.PHONY: rpm srpm dist dirs
+.PHONY: rpm srpm dist
# Build source and binary RPMs.
-rpm: dist dirs
+rpm: dist
rpmbuild $(RPMOPTS) -ba $(SPEC)
# Source RPM only.
-srpm: dist dirs
+srpm: dist
rpmbuild $(RPMOPTS) -bs $(SPEC)
-# Build source distribution.
+# Build source distribution and create required subdirs.
dist:
cd .. && $(MAKE) $(AM_MAKEFLAGS) dist
-
-# Create build directories.
-dirs: BUILD RPMS SOURCES SPECS SRPMS
-BUILD RPMS SOURCES SPECS SRPMS:
- $(MKDIR_P) BUILD RPMS SOURCES SPECS SRPMS
-
+ mkdir -p BUILD RPMS SOURCES SPECS SRPMS