summaryrefslogtreecommitdiff
path: root/cpp
diff options
context:
space:
mode:
Diffstat (limited to 'cpp')
-rw-r--r--cpp/src/tests/Makefile.am3
-rwxr-xr-xcpp/src/tests/reliable_replication_test1
2 files changed, 3 insertions, 1 deletions
diff --git a/cpp/src/tests/Makefile.am b/cpp/src/tests/Makefile.am
index ec34a07e9e..e318942cbf 100644
--- a/cpp/src/tests/Makefile.am
+++ b/cpp/src/tests/Makefile.am
@@ -287,7 +287,8 @@ CLEANFILES+=valgrind.out *.log *.vglog* dummy_test $(unit_wrappers)
# Not run under valgrind, too slow
LONG_TESTS+=start_broker fanout_perftest shared_perftest multiq_perftest topic_perftest run_ring_queue_test run_failover_soak stop_broker \
- reliable_replication_test federated_cluster_test_with_node_failure
+ federated_cluster_test_with_node_failure
+# TODO: renable the temporarily disabled the failing reliable_replication_test when QPID-1984 is resolved.
EXTRA_DIST+=fanout_perftest shared_perftest multiq_perftest topic_perftest run_failover_soak reliable_replication_test \
federated_cluster_test_with_node_failure \
diff --git a/cpp/src/tests/reliable_replication_test b/cpp/src/tests/reliable_replication_test
index 4c507f3dbc..a788d5a76b 100755
--- a/cpp/src/tests/reliable_replication_test
+++ b/cpp/src/tests/reliable_replication_test
@@ -90,6 +90,7 @@ if test -d ${PYTHON_DIR} && test -e ../.libs/replicating_listener.so && test -e
diff replicated.actual replicated.expected || FAIL=1
if [[ $FAIL ]]; then
echo reliable replication test failed: expectations not met!
+ exit 1
else
echo replication reliable in the face of link failures
rm -f replication.actual replication.expected replication-source.log replication-dest.log qpidd-repl.port