summaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/qpid/ops.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/python/qpid/ops.py b/python/qpid/ops.py
index 8c9f8a03e7..390552be6d 100644
--- a/python/qpid/ops.py
+++ b/python/qpid/ops.py
@@ -25,10 +25,12 @@ class Primitive(object):
class Enum(object):
# XXX: for backwards compatibility
- @classmethod
def values(cls):
print >> sys.stderr, "warning, please use .VALUES instead of .values()"
return cls.VALUES
+ # we can't use the backport preprocessor here because this code gets
+ # called by setup.py
+ values = classmethod(values)
class Field: