summaryrefslogtreecommitdiff
path: root/qpid/cpp/CTestConfig.cmake
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/CTestConfig.cmake')
-rwxr-xr-xqpid/cpp/CTestConfig.cmake32
1 files changed, 32 insertions, 0 deletions
diff --git a/qpid/cpp/CTestConfig.cmake b/qpid/cpp/CTestConfig.cmake
new file mode 100755
index 0000000000..7b8a6cb3cf
--- /dev/null
+++ b/qpid/cpp/CTestConfig.cmake
@@ -0,0 +1,32 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+## This file should be placed in the root directory of your project.
+## Then modify the CMakeLists.txt file in the root directory of your
+## project to incorporate the testing dashboard.
+## # The following are required to uses Dart and the Cdash dashboard
+## ENABLE_TESTING()
+## INCLUDE(CTest)
+set(CTEST_PROJECT_NAME "qpid-cpp")
+set(CTEST_NIGHTLY_START_TIME "20:00:00 EST")
+
+set(CTEST_DROP_METHOD "http")
+set(CTEST_DROP_SITE "www.riverace.com")
+set(CTEST_DROP_LOCATION "/CDash-1.4.2/submit.php?project=qpid-cpp")
+set(CTEST_DROP_SITE_CDASH TRUE)